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skilltec Manage Citrix Endpoint
training Management

Moving forward in knowledge and training

Course Code CEM205
Duration 3 days

Overview

Students will explore how to manage Citrix Endpoint Management in this three-day course. Venture into the
cloud as students learn to manage devices, apps, and users. Students will learn how the architecture,
management, and communication flow function with Citrix Endpoint Management Service and how they can
fit their organization’s needs. You will learn how to administer their Citrix Endpoint Management environment
and how to support your end users, as well as working with applications and securing a variety of endpoints.

Audience
Built for IT Professionals interested in learning how to manage Citrix Endpoint Management on-premises or
cloud environments using leading practices. Potential students include Administrators and Implementers.

Learning Objectives
By actively participating in this course, you will learn about the following:

How to manage a Citrix Endpoint Management implementation in a On-premises or cloud environment.
How to perform common enterprise mobility management tasks and mobile application management.
Understand the device enrolment process.

How to perform monitoring, troubleshooting, and reporting on a Citrix Endpoint Management Enterprise
solution.

F¥¥ ¥

Pre-Requisites
Attendees should meet the following prerequisites and have knowledge of the following:

» Microsoft Windows Server 2012 R2 or Windows Server 2008 R2, and Microsoft Windows 8.1 or
Windows 7.

» Mobile device operating systems, such as iOS and Android.

» Network architecture and terminology.
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Course Contents

Module 1: Introduction to Citrix Endpoint Management
» Citrix Endpoint Management Features
» Citrix Cloud and Citrix Endpoint Management
» Citrix Endpoint Management User Experience and Security
» Citrix Endpoint Management Entitlements

Module 2: Citrix Endpoint Management Architecture
Citrix Endpoint Management Prerequisites

Citrix Endpoint Management Server

Citrix Endpoint Management and Microsoft Intune
Apple APNs and Google Firebase Cloud Messaging
MDX Architecture and Features

F¥FIFIFY

Module 3: Cloud Components

Cloud Component Overview

Onboarding and Access

Cloud Connector and Cloud Resource Locations
Cloud Migration

Cloud Updates and Features

F¥FIF¥FI¥Y

Module 4: Common Device Management Tasks
» Administrative Console Overview
» Delivery Groups
» Device Policies

Module 5: Device Enrolment
Enrolment Methods

iOS Device Enrolment
Android Device Enrolment
Windows 10 Enrolment
Other Devices

F¥I¥F ¥V

Module 6: Managing Device Security
Security Policies

Automated Actions

Android for Work

ActiveSync Filtering

Shared Devices

F¥FIFIFY

Module 7: Working with Apps
» Application Integration
»  Citrix Endpoint Management Productivity Apps
» Application Security with MDX
» 3rd Part Applications

Module 8: Integrating Citrix Content Collaboration
» Citrix Content Collaboration Overview
» Integrating Citrix Endpoint Management with Content Collaboration
» Content Collaboration Workflows
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Module 9: Maintaining and Troubleshooting

Maintaining Citrix Endpoint Management

Maintaining Certificates

Troubleshooting Citrix Gateway (formerly NetScaler Gateway)
Troubleshooting Tools for Citrix Productivity Apps

Firewall Issues

F¥I¥F ¥V

Module 10: Monitoring and Reporting
» Monitoring and Reporting of Devices
» Monitoring and Reporting of Citrix Content Collaboration

Exam Details
This course is recommended as preparation for the following assessment:
» Citrix Endpoint Management Certified (CC-CEM-4070500)
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skilltec Citrix Content
training Collaboration Enterprise

Moving forward in knowledge and training ESS e n ti al S
Course Code CSF201
Duration 2 days
Overview

In this two-day course, you will learn about enterprise file sharing and synchronization with Citrix Content
Collaboration. You will gain the skills and understanding needed to configure and manage your Citrix Content
Collaboration environment, including implementation of StorageZones and Citrix Virtual Apps and Desktop
clients. Additionally, explore your control plane and data storage options, end-user management, and client
deployments on Windows physical and virtual desktops.

This course will give you an understanding of Content Collaboration administrative responsibilities and teach
you how to navigate the administrative console for facilitated deployment and file sharing success. This
course is designed for IT professionals with little Citrix Content Collaboration experience.

Audience
This course is designed for IT Professionals interested in learning how to implement Citrix Content
Collaboration features using leading practices.

Learning Objectives
By actively participating in this course, you will learn about the following:

» Understand Enterprise File Synchronization, Sharing, and Citrix Content Collaboration architecture.

» How to navigate the Citrix Content Collaboration administration interface and build StorageZones.

» How to integrate Citrix Content Collaboration in an existing Citrix Virtual Apps and Desktops
environment.

» How to manage Citrix Content Collaboration users in an Active Directory environment.

Pre-Requisites

» Basic understanding of: Windows Server administration, Citrix Virtual Apps and Desktops, Microsoft
Exchange and Outlook, and Basic Enterprise File Synchronization and Sharing.
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Course Contents

Enterprise File Synchronization and Sharing (EFSS) Overview
» Enterprise Document Sharing Use Cases
» Software as a Service (SaaS) and Cloud concepts
» EFSS Legal Basics

Architecture
» Control Plane
» Data Storage Options (Azure, Amazon, Enterprise)
» Security (File Encryption, Password Policy, DLP Overview)

Administration
» Folder Administration
» Advanced Preferences
» Manual User setup

StorageZones
» Component’s data flow
» Restricted Zones Overview
» Connectors Overview (CIFS, SharePoint)

User Management
» ShareFile User Management (UMT) Tool
» Security Assertion Markup Language (SAML) Overview
» Citrix Content Collaboration Authentication

Endpoint Clients
» Windows and Citrix Virtual Apps and Desktop Client
» Mobile Clients
» Outlook Plug-in

User Experience
» Getting Started
» File Management
» Preference Customization

Troubleshooting and Management
» Authentication and Access Issues
» Component upgrade
» Component monitoring

Exam Details

This course is recommended as preparation for the following assessment:

» 1Y0-100 - Understanding Citrix Sharefile Assessment
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skilltec Citrix Virtual Apps &
training Desktops 7 App Layering

Moving forward in knowledge and training an d WE I\/I Ad m i n i Strati 0 n
(Accelerated)
Course Code CMB318
Duration 5 days
Overview

This accelerated 5-day course is designed for experienced IT professionals to build the foundational
administration aspects of installing, configuring and managing a Citrix Virtual Apps and Desktops 7
environment. Learn about configuring policies, printing and basic security features as well as more advanced
topics including Windows Environment Management (WEM) and App Layering. Gain an understanding of the
solution architecture and communications, and the factors that contribute to a successful deployment.
Monitoring and troubleshooting the environment with Citrix Director and Citrix Analytics is also incorporated in
this course.

Audience

Built for experienced IT Professionals new to Citrix Virtual Apps and Desktops 7 in an on-prem or Citrix Cloud
environment looking to gain as much information as possible in the 5-day course. In this course, you will learn
the considerations and how-to setup a new Citrix Virtual Apps and Desktop site including advanced topics as
WEM and App Layering allowing fast-track preparation for the CCP-V certification.

Learning Objectives
By actively participating in this course, you will learn about the following:

» Install, configure and manage a Citrix Virtual Apps and Desktops 7 site on-premises and on Citrix
Cloud including how to migrate from on-premises to Citrix Cloud.

» Configure Workspace Environment Management to improve the end user environment and virtual
resource consumption.

» Use App Layering skills to create and administer OS, platform, application, elastic and user layers.

» Deploy and deliver apps and desktops to end users using Machine Creation Services (MCS).

Pre-Requisites

» Experience with previous versions of Citrix Virtual Apps or Citrix Virtual Desktops is beneficial due to
the faster pace of this course.
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Course Contents

Architecture Overview

Introduction to Citrix Virtual Apps and Desktops
Architecture Overview

Features

Hosting Platform Considerations

Citrix Virtual Apps and Desktops Service
Connection Flow Process Introduction

F¥FIFIFTIFY¥

Deploy the Site

Pre-Deployment Considerations
Citrix Licensing Setup

Delivery Controller Setup

Site Setup and Management
Redundancy Considerations

F¥FI¥F ¥V

The Apps and Desktops Images
» Consider Master Image Creation Methods
» Master Image Requirements

Provision and Deliver App and Desktop Resources
Learning Objectives

Machine Catalogs and Delivery Groups
Provisioning Methods and Considerations
Machine Creation Services (MCS) Deep Dive
MCS Environment Considerations

Resource Locations

FI¥FIFIF ¥V

Provide Access to App and Desktop Resources
» Consider Workspace Experience versus StoreFront
» Workspace App

Manage the User Experience
» Methods to Manage the User Experience

Published App and Desktop Presentation and Management
Published App Properties

Server OS Published App Optimizations

Published App Presentation

Application Groups

Apps and Desktops Presentation

F¥FI¥F ¥V

Manage Printing for User Sessions
» Map Printers to the User Session
» Printer Drivers
»  Print Environment Considerations

Citrix Profile Management
» Introduction and Considerations
» Configure Citrix Profile Management

Manage the Site
» Delegated Administration
» Power Management Considerations
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Citrix Virtual Apps and Desktops Basic Security Considerations
» Citrix Admin Security Considerations
» XML Service Security Considerations
» Secure HDX External Traffic

Monitor the Site

Citrix Director Introduction

Monitor and Interact with User Sessions
Published Apps Analysis

Monitor the Machines Running the VDA
Alerts and Notifications

F¥FIFIFY

Introduction to Supporting and Troubleshooting Citrix Virtual Apps and Desktops

» Introduction to Supporting a Citrix Virtual Apps and Desktops Site
» Tools

Migrate to Citrix Cloud
» Migration Considerations
» Citrix Cloud Connector Deployment

»  Citrix Virtual Apps and Desktops with an On-Premises Resource Location

» The Migration Process

Citrix Analytics
» Citrix Analytics Introduction
» Types of Analytics

Introduction to App Layering
» App Layering Introduction
» Architecture and How it Works

Create an OS Layer
» The OS Layer

Create a Platform Layer
» The Platform Layer

Create App Layers
» The App Layers

Create Elastic App and User Layers
» Elastic App Layering
» User Layers

Deploy a Layered Image using Citrix Virtual Apps and Desktops
» Using Templates in App Layering
» Using Layered Images in a Citrix Virtual Apps and Desktops Site

Explore Layer Priority and Maintain an App Layering Environment
» Layer Priority
» Updating Layers
» Maintaining and Updating the App Layering Environment
» Common App Layering Considerations and Additional Resources
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Introduction to Workspace Environment Management (WEM)
» Workspace Environment Management (WEM) Introduction
» WEM Administration

Use WEM to Centralize Environment Management
» Managing User Resources with WEM
» Managing Profiles with WEM
» Managing Endpoints with the WEM Transformer Feature

Use WEM for Performance Optimization
» Learning Objectives
» Optimizing Machine Performance with WEM
» Optimizing User Experience with WEM

Use WEM to Secure Environments
» Use WEM to Secure Environments
» WEM Security Features

Migrate and Upgrade WEM
» Migrating to WEM
» Upgrading a WEM Deployment
» WEM Multi-Location Considerations

Exam Details

This course is recommended as preparation for the following exams:

» 1Y0-203 - Citrix XenApp and XenDesktop 7.15 Administration required for CCA-V Associate level

Virtualization Certification

» 1Y0-311 - Citrix XenApp and XenDesktop 7.15 Advanced Administration required for CCP-V

Professional Level Virtualization Certification

Please note attendance of the CWS-313 - Citrix Virtual Apps and Desktops 7 Backup, Recovery, Security and

Troubleshooting is recommended before attempting the 1Y0-311 exam.

The Citrix Certified Associate - Virtualization (CCA - V) validates the skills IT operators and administrators
need to install, configure and manage a highly available environment comprised of Citrix Virtual Apps and

Desktops Delivery Controllers, StoreFront, Citrix Receiver, Director, Studio and Profile management.

The Citrix Certified Professional - Virtualization (CCP - V) validates the skills experienced IT solution builders,
such as engineers and consultants, need to manage and support complex environments based on Citrix

Virtual Apps and Desktops with Provisioning Services
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skilltec Citrix Virtual Apps &
training Desktops 7 on Premises

Moving forward in knowledge and training an d C Itr I X C I 0 u d
Course Code CWsS215
Duration 5 days
Overview

If you are new to Citrix or if you are planning a move to Citrix Cloud, this course is a necessary step in
enabling you with the right training and skills to manage and deploy Citrix Workspace successfully. This
foundational administration course covers the aspects of installing, configuring and managing a Citrix Virtual
Apps and Desktops 7 environment, how to manage an on-premises Citrix solution and migrate from an on-
premises solution to cloud using the Citrix Cloud management plane.

This five-day course will teach you how to deploy, install, configure, setup profile management, configure
policies, printing and basic security features for on-premises Virtual Apps and Desktop solution building, and
then migrating to Citrix Cloud.

Audience

Experienced IT Professionals who want to be familiar with Citrix Virtual Apps and Desktops 7 in an on-
premises environment and Citrix Cloud. Potential students include administrators or engineers responsible for
the end user workspace and overall health and performance of the solution.

Learning Objectives
By actively participating in this course, you will learn about the following:

» Install, configure, and manage a Citrix Virtual Apps and Desktops 7 site and Cloud connectors.

» Identify the considerations between Citrix Virtual Apps and Desktops on-premises and the Citrix Virtual
Apps and Desktops Service.

» Deliver app and desktop resources.

Pre-Requisites

This course requires basic knowledge of AD, Windows, Storage, Networking and little to no previous
experience with the Citrix Virtual Apps and Desktops 7 version; however, Citrix recommends completing the
free Citrix Virtual Apps and Desktops 7 Introduction bundle at elearning.citrix.com.
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Course Contents

Architecture Overview

Introduction to Citrix Virtual Apps and Desktops
Architecture Overview

Features

Hosting Platform Considerations

Citrix Virtual Apps and Desktops Service
Connection Flow Process Introduction

F¥FIFIFTIFY¥

Deploy the Site

Pre-Deployment Considerations
Citrix Licensing Setup

Delivery Controller Setup

Site Setup and Management
Redundancy Considerations

F¥FI¥F ¥V

The Apps and Desktops Images
» Consider Master Image Creation Methods
» Master Image Requirements

Provision and Deliver App and Desktop Resources
Machine Catalogs and Delivery Groups
Provisioning Methods and Considerations
Machine Creation Services (MCS) Deep Dive
MCS Environment Considerations

Resource Locations

F¥IF¥FI¥Y

Provide Access to App and Desktop Resources
Consider Workspace Experience versus StoreFront
Workspace Experience User Authentication
Workspace App

Communication Flow

F¥I¥ ¥

Manage the User Experience
» Methods to Manage the User Experience
» Common User Experience Settings

Published App and Desktop Presentation and Management
Published App Properties

Server OS Published App Optimizations

Published App Presentation

Application Groups

Apps and Desktops Presentation

F¥FIFIF¥

Manage Printing for User Sessions
» Map Printers to the User Session
» Printer Drivers
» Print Environment Considerations

Citrix Profile Management
» Introduction and Considerations
» Configure Citrix Profile Management
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Manage the Site
» Delegated Administration
» Use PowerShell with Citrix Virtual Apps and Desktops
» Power Management Considerations

Citrix Virtual Apps and Desktops Basic Security Considerations
»  Citrix Admin Security Considerations
» XML Service Security Considerations
» Secure HDX External Traffic

Monitor the Site
»  Citrix Director Introduction
» Monitor and Interact with User Sessions
» Published Apps Analysis
» Monitor the Machines Running the VDA
» Site Specific Common Monitoring
» Alerts and Notifications
» Optimize Citrix Director Monitoring with Citrix ADM

Introduction to Supporting and Troubleshooting Citrix Virtual Apps and Desktops
» Introduction to Supporting a Citrix Virtual Apps and Desktops Site
» Tools
» Proactive Administration Common Tasks

Migrate to Citrix Cloud
» Migration Considerations
» Citrix Cloud Connector Deployment
»  Citrix Virtual Apps and Desktops with an On-Premises Resource Location
» The Migration Process

Citrix Analytics
» Citrix Analytics Introduction
» Prepare to Use Citrix Analytics
» Types of Analytics

Exam Details
This course is recommended as preparation for the following exam:

» CCA-V Certification exam.
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skilltec Citrix Virtual Apps &
training Desktops 7 Advanced

Moving forward in knowledge and training D e p I Oym e nt —
Troubleshooting, Security
& Administration

Course Code CWS313
Duration 3 days

Overview

Designed for experienced IT professionals this course builds on foundational implementation and
management skills by introducing scalability, redundancy and security configurations. Learn the techniques
required to investigate many of the common issues that can affect the environments health and understand
how to solve issues more effectively in the advanced troubleshooting section. You will leave this course with a
good understanding of how to manage more complex solutions such as multi-location environments with
configurations around StoreFront, the Delivery Controllers, Cloud Connectors and HDX.

Audience

Built for experienced IT Professionals familiar with Citrix Virtual Apps and Desktops 7 in an on-premises
environment or Citrix Cloud looking to expand their Citrix Virtual Apps and Desktops skills to an advanced
level. Potential students include administrators or engineers responsible for the Citrix Apps and Desktop 7
Site.

Learning Objectives
By actively participating in this course, you will learn about the following:

» Implement advanced administration concepts such as backups, disaster recovery, scalability and
redundancy consideration for a Citrix Virtual Apps and Desktop 7 Site.

» Employ Advanced troubleshooting techniques to troubleshoot Citrix Apps and Desktop 7.

»  Apply Security considerations and configurations for Citrix Apps and Desktop 7 site including multi-site
management using zones.

Pre-Requisites

» Strong foundational knowledge of Citrix Virtual Apps and Desktops 7.

»  Citrix recommends students prepare for this course by taking either CWS-215 Citrix Virtual Apps and
Desktops 7 Administration On-Premises and in Citrix Cloud or CMB-318 - Citrix Virtual Apps and
Desktops 7, App Layering, and WEM Administration (Fast-Track).

Course Contents

Implementing Redundancy and Scalability
» StoreFront and Citrix Gateway
» Site Infrastructure
» Machines Running the Virtual Delivery Agent
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Managing a Virtual Apps and Desktops Environment with Multiple Locations Zones
VDA Registration in a Multi-Zone Environment

Zone Preference

Optimal Gateway Routing and Zones

Managing StoreFront Store Subscriptions in a MultiLocation Environment
StoreFront and Citrix ADC Branding

F¥F¥F ¥

Implementing Backups and Disaster Recovery
» Backups
» Disaster Recovery Considerations
» Disaster Recovery Process

Implementing Advanced Authentication Methods
» Multi-factor Authentication - RADIUS & OTP
» Multi-factor Authentication - Smart Card Authentication
» Federated Authentication - ADFS, SAML, and FAS

Improving App and Data Security
» Introduction to Application Security
» Preventing Jailbreak Attacks
» Minimizing the Impact of Attacks

Securing Machines Running the Virtual Delivery Agent
» TLS to VDA Encryption
» GPOs and Citrix Policies
» Image Management Troubleshooting techniques and tools

Introduction to Troubleshooting
» Troubleshooting Methodology Process (Standard Slide)
» Resource Tools and Utilities
» Introduction to PowerShell

Troubleshooting Access Issues
» Troubleshooting StoreFront
» Troubleshooting Citrix Gateway

Troubleshooting Delivery Controller Issues
» Validating FMA Services

Troubleshooting VDA Registration Issues
» Troubleshooting VDA Registration

Troubleshooting HDX Connection Issues
» Troubleshooting HDX Connections

Exam Details
This course is recommended as preparation for the following exams:
» CCP-V Certification Exam

Please note students will also need to study either the CWS-314 Course or the CWS-316 course before

attempting this exam.
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skilltec Citrix Virtual Apps &
training Desktops 7 Advanced

Moving forward in knowledge and training Ad m I n I St ratl O n
Course Code CWsS315
Duration 5 days
Overview

Designed to learn how to set up scalability, redundancy and security configurations. You will learn advance
features to optimize management of your app and desktop images by building and combining App Layers and
Workspace Environment Management, which can improve logon times, centralize user settings management,
optimize the performance of machines running the Virtual Delivery Agent (VDA).

In the advanced troubleshooting section, you will learn technigues to investigate many of the common issues
that can affect environment health. You will leave this course with a good understanding of how to manage
more complex solutions such as multizone environments spanning multiple locations with configurations
around StoreFront, the Delivery Controllers, and HDX.

Audience

Built for experienced IT Professionals familiar with Citrix Virtual Apps and Desktops 7 in an on-premises
environment or Citrix Cloud looking to expand their Citrix Virtual Apps and Desktops skills to an advanced
level. Potential students include administrators or engineers responsible for the Citrix Apps and Desktop 7
Site.

Learning Objectives
By actively participating in this course, you will learn about the following:

» Implement advanced administration concepts such as backups, disaster recovery, scalability and
redundancy consideration for a Citrix Virtual Apps and Desktop 7 Site.

» Configure Workspace Environment Management to improve the end user environment and virtual
resource consumption.

» Implement App Layering skills, for example how to create and administer OS, platform, application,
elastic and user layers.

» Use Advanced troubleshooting techniques to troubleshoot Citrix Apps and Desktop 7

» Apply Security considerations and configurations for Citrix Apps and Desktop 7 site including multi-site
management using zones.

Pre-Requisites
» Strong foundational knowledge of Citrix Virtual Apps and Desktops 7.

»  Citrix recommends students prepare for this course by taking the following course: CWS-215 Citrix
Virtual Apps and Desktops 7 Administration On-Premises and in Citrix Cloud.
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Course Contents

Implementing Redundancy and Scalability
» StoreFront and Citrix Gateway
» Site Infrastructure
» Machines Running the Virtual Delivery Agent

Managing a Virtual Apps and Desktops Environment with Multiple Locations Zones
VDA Registration in a Multi-Zone Environment

Zone Preference

Optimal Gateway Routing and Zones

Managing StoreFront Store Subscriptions in a MultiLocation Environment
StoreFront and Citrix ADC Branding

F¥F¥F ¥

Implementing Backups and Disaster Recovery
» Backups
» Disaster Recovery Considerations
» Disaster Recovery Process

Implementing Advanced Authentication Methods
» Multi-factor Authentication - RADIUS & OTP
» Multi-factor Authentication - Smart Card Authentication
» Federated Authentication - ADFS, SAML, and FAS

Improving App and Data Security
» Introduction to Application Security
» Preventing Jailbreak Attacks
» Minimizing the Impact of Attacks

Securing Machines Running the Virtual Delivery Agent
» TLS to VDA Encryption
» GPOs and Citrix Policies
» Image Management Troubleshooting techniques and tools

Introduction to Troubleshooting
» Troubleshooting Methodology Process (Standard Slide)
» Resource Tools and Utilities
» Introduction to PowerShell

Troubleshooting Access Issues
» Troubleshooting StoreFront
» Troubleshooting Citrix Gateway

Troubleshooting Delivery Controller Issues
» Validating FMA Services

Troubleshooting VDA Registration Issues
» Troubleshooting VDA Registration

Troubleshooting HDX Connection Issues
» Troubleshooting HDX Connections
Introduction to App Layering
» App Layering Introduction
»  Architecture and How it Works
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Creating an OS Layer
» The OS Layer

Creating a Platform Layer
» The Platform Layer

Creating App Layers
» The App Layers Module

Creating Elastic App and User Layers
» Elastic App Layering
» User Layers

Deploying a Layered Image using Citrix Virtual Apps and Desktops
» Using Templates in App Layering
» Using Layered Images in a Citrix Virtual Apps and Desktops Site

Exploring Layer Priority
» Layer Priority

Maintaining an App Layering Environment
» Updating Layers
» Maintaining and Updating the App Layering Environment
» Common App Layering Considerations and Additional Resources

Introduction to Workspace Environment Management (WEM)
» Workspace Environment Management (WEM) Introduction
» WEM Administration

Using WEM to Centralize Environment Management
» Managing User Resources with WEM
» Managing Profiles with WEM
» Managing Endpoints with the WEM Transformer Feature

Using WEM for Performance Optimization
» Optimizing Machine Performance with WEM
» Optimizing User Experience with WEM

Using WEM to Secure Environments
» WEM Security Features

Migrating and Upgrading WEM
» Migrating to WEM
» Upgrading a WEM Deployment
» WEM Multi-Location Considerations

Exam Details
There is no exam associated with this course
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skilltec Citrix Virtual Apps &
training Desktops 7 Assessment,

Moving forward in knowledge and training Des i g n an d Ad Van Ced
Configuration
Course Code  Cws415
Duration 5 days
Overview

This advanced 5-day training course teaches the design principles for creating a Citrix Virtual Apps and
Desktops virtualization solution. In this training, you will learn how to assess existing environments, explore
different scenarios and make design decisions based on business requirements.

This course covers the Citrix Consulting approach to design and covers the key design decisions through
lectures, lab exercises, and interactive discussions. Additional considerations and advanced configurations for
multi-location solutions and disaster recovery planning are also incorporated into this class.

Audience

IT Professionals with significant experience with Citrix Virtual Apps and Desktops 7 as well as supporting
infrastructure. If you are responsible for the environment design and overall health or are guiding others
through the process (as a consultant), you should consider taking this training.

Learning Objectives
By actively participating in this course, you will learn about the following:

» Identify risks and areas for improvement in a Citrix Virtual Apps and Desktops environment by
assessing relevant information in an existing deployment.

» Determine core Citrix Virtual Apps and Desktops design decisions and align them to business
requirements to achieve a practical solution.

» Design a Citrix Virtual Apps and Desktops disaster recovery plan and understand different disaster
recovery considerations.

Pre-Requisites
Attendees should meet the following prerequisites:

» Extensive experience with Citrix Virtual Apps and Desktops 7 as well as experience with Citrix

Gateway and supporting infrastructure.
» Attendance of CXD-310 or CWS-315 is recommended.
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Course Contents

Methodology & Assessment

F¥FI¥FTI¥Y

Methodology

Business Drivers

User Segmentation
Application Assessment
Capabilities Assessment

User Layer

»
»
»

Endpoints & Peripherals
Citrix Workspace App
Network Connectivity

Access Layer

»

»
»
»

Access Matrix*

Access Layer Architecture Design Considerations

StoreFront Store Design
Scalability and Redundancy

Resource Layer - Images

»

»
»
»

FlexCast Model Assignment*

Virtual Delivery Agent Machine Scalability
Virtual Delivery Agent Machine Security
Provisioning Strategy / Image Management

Resource Layer - Applications and Personalization

»

»
»
»

Application Delivery
Profiles

Policies

Printing*

Control Layer

F¥FIF¥FIFY

Citrix Virtual Apps and Desktops Site Design
Machine Catalogs & Delivery Groups*

Site Management Considerations

Control Layer Scalability & High Availability
Control Layer Security

Disaster Recovery

»
»
»

Disaster Recovery - Levels
Disaster Recovery - Strategy
Disaster Recovery — Process

*Optional content based on instructor criteria

Exam Details
There is no exam directly related to this course.
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skilltec Moving to the Citrix

training Virtual Apps and
Moving forward in knowledge and training D es kto pS Se er ce on

Citrix Cloud

Course Code CXD250
Duration 3 days

Overview

This course is designed for students with previous experience with XenApp and XenDesktop on-prem. You
will learn how to navigate the move from XenApp and XenDesktop on-premises to the Citrix Cloud. Get
hands-on as the course guides you through the architecture, communications, management, installation, and
configuration of Citrix Cloud and the Cloud Connector. You will gain an understanding of the many services
available in Citrix Cloud and understand the considerations for migrating resources to a public cloud. If you
are planning or considering a move to the Citrix Cloud, this course is a necessary step in enabling you with
the right training and skills to understand, manage, and deliver a successful migration.

Audience
Built for IT Professionals who are responsible for migrating or supporting some or all of their on-premises
XenApp and XenDesktop infrastructure to the XenApp and XenDesktop Service on Citrix Cloud.

Learning Objectives
By actively participating in this course, you will learn about the following:

Describe the architecture and communications of the Citrix Cloud.

Understand the differences between XenApp and XenDesktop on-premises and the XenApp and
XenDesktop Service.

Describe the services and resources available through Citrix Cloud.

Install, configure, and manage Citrix Cloud Connectors.

Deliver app and desktop resources to on-premises resource locations.

Understand considerations for StoreFront and NetScaler Gateway locations with Citrix Cloud.
Migrate existing on-premises XenApp and XenDesktop infrastructure to the Citrix Cloud.
Understand considerations for migrating resources to a public cloud.

¥ ¥
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Pre-Requisites
It is recommended that students meet the following prerequisites:

» Familiarity of basic cloud services concepts.
Recommended prerequisites:

» CWS-215 - Citrix Virtual Apps and Desktops 7 Administration On-Premises and in Citrix Cloud.
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Course Contents

Introduction to Citrix Cloud
» What is Citrix Cloud
» Citrix Cloud Services
» Citrix Cloud Operation and Architecture
» Citrix Cloud Administration

Citrix Cloud Connectors
» Cloud Connector Architecture
» Installing and configuring Citrix Cloud Connectors

Introduction to the XenApp and XenDesktop Service
» XenApp and XenDesktop Deployment Models
» XenApp and XenDesktop Service with On-Premises Resources
» Configuring the XenApp and XenDesktop Service
» Delivering Apps and Desktop to End-Users Using On-Premises Resources

Managing the XenApp and XenDesktop Service
» Citrix Studio and Director
» XenApp and XenDesktop Remote PowerShell SDK
» Managing Multiple Resource Locations
» Using PVS with the XenApp and XenDesktop Services

Providing Access with StoreFront and NetScaler in Citrix Cloud
» Consideration for StoreFront Locations
» Consideration for NetScaler Gateway Locations
» Configuring StoreFront and NetScaler Gateway Access in Citrix Cloud

Public Cloud Considerations
» General Public Cloud Considerations
» Microsoft Azure as a Citrix Cloud Resource Location (Lecture only)
» Amazon Web Services as a Citrix Cloud Resource Location (Lecture only)

On-Premises Migration to the XenApp and XenDesktop Service
» Citrix Cloud Migration Options and Considerations
» Migrating Policies and Settings
» Migrating Machine Catalogs and Delivery Groups
» Considerations for Migrating to a Public Cloud

Exam Details
There is no exam directly related to this course.
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skilltec Citrix Virtual Apps &
trainine Desktop Service on

Moving forward in knowledge and training M I C rOS Oft AZ u re
Course Code CXD251
Duration 2 days
Overview

Learn to deploy and manage your XenApp and XenDesktop apps and desktops in Microsoft Azure. Gain the
skills to plan your machine catalog and virtual machine design based in Microsoft’s public cloud and get
hands-on practice deploying those machines using Machine Creation Services. You will also learn about
additional Azure considerations including maintenance and power management which are critical in a cloud
environment. For remote access, you will learn to configure Citrix StoreFront and NetScaler Gateway on the
Azure platform.

This course focuses on Microsoft Azure as a Citrix Cloud resource location, however concepts are relevant to
both Citrix Cloud and fully managed XenApp and XenDesktop sites. If you are planning to move to Citrix
Cloud, it is recommended that you enrol in CXD-252 Moving to the XenApp and XenDesktop Service on Citrix
Cloud and Microsoft Azure which includes both Citrix Cloud architecture and administration in addition to the
content covered in this course in a 5-day format.

Audience

Built for experienced IT Professionals familiar with XenApp and XenDesktop 7.x in an on-premises
environment. Potential students include administrators, engineers, and architects designing or deploying
XenApp and XenDesktop workloads on Microsoft Azure.

Learning Objectives
By actively participating in this course, you will learn about the following:

» Prepare the Azure environment for secure integration with XenApp and XenDesktop.

» Deploy and manage Virtual Delivery Agent machines in Microsoft Azure using Machine Creation
Services.

» Integrate Citrix Cloud and XenApp/XenDesktop with Microsoft Azure Active Directory.

» Design Machine Catalogs and virtual machines on Microsoft Azure Resource Manager.

» Provide remote access with Citrix StoreFront and NetScaler Gateway on Microsoft Azure.

Pre-Requisites
Attendees should meet the following prerequisites:
» Experience deploying and managing XenApp and XenDesktop 7.x in on-premises environment.
» Basic knowledge of the Microsoft Azure platform including Virtual machine management, Azure
Resource Manager portal, Storage and Networking.

Recommended prerequisites:

» CWS-215 - Citrix Virtual Apps and Desktops 7 Administration On-Premises and in Citrix Cloud.
» CXD-250 - Moving to the Citrix Virtual Apps and Desktop Service on Citrix Cloud.
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Course Contents

Module 1: XenApp and XenDesktop on Azure Overview
Defining IAAS

XenApp and XenDesktop Azure Deployment Models
Azure Fundamentals Review

Azure Management

Azure Locations
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Module 2: XenApp and XenDesktop

Integration with Azure Active Directory

Active Directory Basics

Active Directory Usage

Connecting On-premises Active Directory to Azure
Azure Role Based Access Control
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Module 3: Connecting to Microsoft Azure
» Azure Connectivity
» Cloud Connectors in Azure
» Creating XenApp and XenDesktop Host Connections to Azure

Module 4: Deploying Apps and Desktops using Machine Creation Services

» Master Image Preparation
» Machine Creation Services in Azure
» Considerations for Deploying onto Azure

Module 5: Providing Access to End Users
» StoreFront Locations
» NetScaler Locations
» Multiple XenApp and XenDesktop Zones in Azure Regions

Module 6: Maintaining Infrastructure and VDASs in Microsoft Azure
» Maintaining Infrastructure
» Maintaining Resources
» Power Management

Module 7: Plan for a Successful POC
» Planning your next steps

Exam Details
There is no exam directly related to this course.

Page 25 of 28



skilltec Moving to the Citrix
training Virtual Apps & Desktops

Moving forward in knowledge and training SerVice On CitriX CIOUd
with MS Azure

Course Code CXD252
Duration 5 days

Overview

Navigate the move from an on-premises environment into Citrix Cloud and learn to deploy resource locations
onto Microsoft Azure. Learn the architecture, communications, and management of Citrix Cloud and the
XenApp and XenDesktop Service and then migrate existing infrastructure and settings into Citrix Cloud. Plan
machine catalog and virtual machine design based in Microsoft’s public cloud and deploy those machines
using Machine Creation Services. Additional Azure considerations include maintenance and power
management. Learn to configure Citrix StoreFront and NetScaler Gateway as a service within Citrix Cloud or
as managed machines in your datacenter or on the Azure platform for remote access.

Audience

Built for experienced IT Professionals familiar with XenApp and XenDesktop 7.x in an on-premises
environment moving to the Citrix Cloud and deploying their XenApp and XenDesktop workloads on Microsoft
Azure.

Learning Objectives
By actively participating in this course, you will learn about the following:

» Understand the differences between XenApp and XenDesktop on-premises and the XenApp and
XenDesktop Service.

» How to install, configure, and manage Citrix Cloud Connectors.

» Deploy and manage Virtual Delivery Agent machines to on-premises resource locations as well as in
Microsoft Azure using MCS.

» Integrate Citrix Cloud and XenApp/XenDesktop with Microsoft Azure Active Directory.

» Provide remote access with Citrix StoreFront and NetScaler Gateway on Microsoft Azure.

Pre-Requisites
Attendees should meet the following prerequisites:

» Experience deploying and managing XenApp and XenDesktop 7.x in on-premises environment.
» Basic knowledge of the Microsoft Azure platform including: Virtual machine management, Networking,
Storage, Azure Resource Manager portals.

Recommended prerequisites:

» CWS-215 - Citrix Virtual Apps and Desktops 7 Administration On-Premises and in Citrix Cloud.
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Course Contents

Module 1: Introduction to Citrix Cloud
» What is Citrix Cloud
» Citrix Cloud Services
» Citrix Cloud Operation and Architecture
» Citrix Cloud Administration

Module 2: Citrix Cloud Connectors
» Cloud Connector Architecture
» Installing and configuring Citrix Cloud Connectors

Module 3: Introduction to the XenApp and XenDesktop Service
» XenApp and XenDesktop Deployment Models
» XenApp and XenDesktop Service with On-Premises Resources
» Configuring the XenApp and XenDesktop Service

» Delivering Apps and Desktop to End-Users Using OnPremises Resources with MCS

Module 4: Managing the XenApp and XenDesktop Service
» Citrix Studio and Director
» XenApp and XenDesktop Remote PowerShell SDK
» Managing Multiple Resource Locations
» Using PVS with the XenApp and XenDesktop Services

Module 5: Providing Access with StoreFront and NetScaler in Citrix Cloud
» Consideration for StoreFront Location
» Consideration for NetScaler Gateway Locations
» Configuring StoreFront and NetScaler Gateway Access in Citrix Cloud

Module 6: Public Cloud Considerations
» General Public Cloud Considerations
» Microsoft Azure as a Citrix Cloud Resource Location (Lecture only)
» Amazon Web Services as a Citrix Cloud Resource Location (Lecture only)

Module 7: On-Premises Migration to the XenApp and XenDesktop Service
» Citrix Cloud Migration Options and Considerations
» Migrating Policies and Settings
» Migrating Machine Catalogs and Delivery Groups
» Considerations for Migrating to a Public Cloud

Module 8: XenApp and XenDesktop on Azure Overview
Defining IAAS

XenApp and XenDesktop Azure Deployment Models
Azure Fundamentals Review

Azure Management

Azure Locations
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Module 9: XenApp and XenDesktop Integration with Azure Active Directory
» Active Directory Basics
» Active Directory Usage
» Connecting On-premises Active Directory to Azure
» Azure Role Based Access Control
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Module 10: Connecting to Microsoft Azure
» Azure Connectivity
» Cloud Connectors in Azure
» Creating XenApp and XenDesktop Host Connections to Azure

Module 11: Deploying Apps and Desktops using Machine Creation Services
» Master Image Preparation
» Machine Creation Services in Azure
» Considerations for Deploying onto Azure

Module 12: Providing Access to End Users
» StoreFront Locations
» NetScaler Locations
» Multiple XenApp and XenDesktop Zones in Azure Regions

Module 13: Maintaining Infrastructure and VDAs in Microsoft Azure
» Maintaining Infrastructure
» Maintaining Resources
» Power Management

Module 14: Plan for a Successful POC
» Planning your next steps

Exam Details
This course is recommended as preparation for the following assessments:

» CC-VAD-MA - Citrix Virtual Apps and Desktops Service Integration with Microsoft Azure
» CC-VAD-CC - Citrix Virtual Apps and Desktops Service on Citrix Cloud Certification
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