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skilltec Designing and
training Implementing a Microsoft

Moving forward in knowledge and training AZ u re AI SO I utl O n
Course Code MAI102
Duration 4 days
Overview

Gain the necessary knowledge for designing Azure Al solution by building a customer support chat Bot using
artificial intelligence from the Microsoft Azure platform including language understanding and pre-built Al
functionality in the Azure Cognitive Services.

Audience
This course is aimed at Cloud Solution Architects, Azure artificial intelligence designers, and Al developers.

Learning Objectives
By actively participating in this course, you will learn about the following:

Planning and managing an Azure Cognitive Services solution.
Implementing Computer Vision solutions.

Implementing natural language processing solutions.
Implementing knowledge mining solutions.

Implementing conversational Al solutions.

FFEFIFIF Y

Pre-Requisites

Successful Azure Al Engineers start this role with professional experience with cloud technologies, and
experience with software development kits.

Specifically:
» Implementing solutions in C# or Python
»  Application development in the cloud
» Understanding Azure storage technologies

Course Contents

Module 1: Introducing Azure Cognitive Services
The delegate will learn about the available Cognitive Services on Microsoft Azure and their role in architecting
Al solutions.

Lessons
»  Overview of Azure Cognitive Services
» Creating a Cognitive Service on the Azure Portal
» Access and Test a Cognitive Service
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Module 2: Creating Bots
The delegate will learn about the Microsoft Bot Framework and Bot Services.

Lessons
» Introducing the Bot Service
» Creating a Basic Chat Bot
»  Testing with the Bot Emulator

Module 3: Enhancing Bots with QnA Maker
The delegate will learn about the QnA Maker and how to integrate Bots and QnA Maker to build up a useful
knowledge base for user interactions.

Lessons
» Introducing QnA Maker
» Implement a Knowledge Base with QnA Maker
» Integrate QnA with a Bot

Module 4: Learn How to Create Language Understanding Functionality with LUIS
The delegate will learn about Language Understanding with Intents and Utterances (LUIS) and how to create
intents and utterances to support a natural language processing solution.

Lessons
» Introducing Language Understanding
» Create a new LUIS Service
» Build LUIS

Module 5: Enhancing Your Bots with LUIS
The delegate will learn about integrating LUIS with a Bot to better understand the users’ intentions when
interacting with the Bot.

Lessons
» Overview of language understanding for Al applications
» Integrate LUIS and Bot to create an Al-based solution

Module 6: Integrate Cognitive Services with Bots and Agents
The delegate will learn about integrating Bots and Agents with Azure Cognitive Services for advanced
features such as sentiment analysis, image and text analysis, and OCR and object detection.

Lessons
» Understand Cognitive Services for Bot Interactions
» Perform Sentiment Analysis for your Bot with Text Analytics
» Detect Language in a Bot with the Language Cognitive Services
» Integrate Computer Vision with Bots

Exam Details
This course leads to the Al-102 Designing and Implementing a Microsoft Azure Al Solution (beta) exam,
which will earn you the Microsoft Certified: Azure Al Engineer Associate certification.
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skilltec Microsoft Azure Al
training Fundamentals

Moving forward in knowledge and training

Course Code MAI900
Duration 1 day

Overview

This course introduces fundamentals concepts related to artificial intelligence (Al), and the services in
Microsoft Azure that can be used to create Al solutions. The course is not designed to teach students to
become professional data scientists or software developers, but rather to build awareness of common Al
workloads and the ability to identify Azure services to support them.

The course is designed as a blended learning experience that combines instructor-led training with online
materials on the Microsoft Learn platform (https://azure.com/learn). The hands-on exercises in the course are
based on Learn modules, and students are encouraged to use the content on Learn as reference materials to
reinforce what they learn in the class and to explore topics in more depth.

Audience

The Azure Al Fundamentals course is designed for anyone interested in learning about the types of solution
artificial intelligence (Al) makes possible, and the services on Microsoft Azure that you can use to create
them. You don’t need to have any experience of using Microsoft Azure before taking this course, but a basic
level of familiarity with computer technology and the Internet is assumed. Some of the concepts covered in
the course require a basic understanding of mathematics, such as the ability to interpret charts. The course
includes hands-on activities that involve working with data and running code, so a knowledge of fundamental
programming principles will be helpful.

Learning Objectives
By actively participating in this course, you will learn about the following:

Describe Artificial Intelligence workloads and considerations

Describe fundamental principles of machine learning on Azure

Describe features of computer vision workloads on Azure

Describe features of Natural Language Processing (NLP) workloads on Azure
Describe features of conversational Al workloads on Azure

FFIFFF

Pre-Requisites
Familiarity with computers and using a web browser.
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Course Contents

Module 1: Introduction to Al
In this module, you'll learn about common uses of artificial intelligence (Al), and the different types of workload
associated with Al. You'll then explore considerations and principles for responsible Al development.

»  Artificial Intelligence in Azure
» Responsible Al

After completing this module, you will be able to
» Describe Artificial Intelligence workloads and considerations

Module 2: Machine Learning

Machine learning is the foundation for modern Al solutions. In this module, you'll learn about some
fundamental machine learning concepts, and how to use the Azure Machine Learning service to create and
publish machine learning models.

» Introduction to Machine Learning
»  Azure Machine Learning

After completing this module, you will be able to
» Describe fundamental principles of machine learning on Azure

Module 3: Computer Vision
Computer vision is the area of Al that deals with understanding the world visually, through images, video files,
and cameras. In this module you'll explore multiple computer vision techniques and services.

» Computer Vision Concepts
» Computer Vision in Azure

After completing this module, you will be able to
» Describe features of computer vision workloads on Azure

Module 4: Natural Language Processing

This module describes scenarios for Al solutions that can process written and spoken language. You'll learn
about Azure services that can be used to build solutions that analyze text, recognize and synthesize speech,
translate between languages, and interpret commands.

After completing this module, you will be able to
» Describe features of Natural Language Processing (NLP) workloads on Azure

Module 5: Conversational Al

Conversational Al enables users to engage in a dialog with an Al agent, or *bot*, through communication
channels such as email, webchat interfaces, social media, and others. This module describes some basic
principles for working with bots and gives you an opportunity to create a bot that can respond intelligently to
user questions.

» Conversational Al Concepts
» Conversational Al in Azure

After completing this module, you will be able to
» Describe features of conversational Al workloads on Azure

Exam Details
This course is recommended as preparation for the exam Al-900: Microsoft Azure Al Fundamentals.
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skilltec Automating
training Administration with

Moving forward in knowledge and training P Owe rS h e I I
Course Code MAZ040
Duration 5 days
Overview

This course provides students with the fundamental knowledge and skills to use PowerShell for administering
and automating administration of Windows servers. This course provides students the skills to identify and
build the command they require to perform a specific task. In addition, students learn how to build scripts to
accomplish advanced tasks such as automating repetitive tasks and generating reports.

This course provides prerequisite skills supporting a broad range of Microsoft products, including Windows
Server, Windows Client, Microsoft Azure, and Microsoft 365. In keeping with that goal, this course will not
focus on any one of those products, although Windows Server, which is the common platform for all of those
products, will serve as the example for the techniques this course teaches.

Audience

This course is intended for IT Professionals who are already experienced in general Windows Server,
Windows client, Azure, and Microsoft 365 administration, and who want to learn more about using Windows
PowerShell for administration. No prior experience with any version of PowerShell or any scripting language is
assumed. This course is also suitable for IT Professionals already experienced in server administration,
including Microsoft Exchange Server, Microsoft SharePoint Server, and Microsoft SQL Server.

Learning Objectives
By actively participating in this course, you will learn about the following:

Describe the functionality of Windows PowerShell and use it to run and find basic commands.
Identify and run cmdlets for local system administration.

Work with the Windows PowerShell pipeline.

Use PSProviders and PSDrives to work with other forms of storage.
Query system information by using WMI and CIM.

Work with variables, arrays, and hash tables.

Create basic scripts in Windows PowerShell.

Administer remote computers with Windows PowerShell.

Manage Azure resources with PowerShell.

Manage Microsoft 365 services with PowerShell.

Use background jobs and scheduled jobs.

FIFIFIFIFIFIFIFIFFY

Pre-Requisites

» Experience with Windows networking technologies and implementation.
»  Experience with Windows Server administration, maintenance, and troubleshooting.
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Course Contents

Module 1: Getting Started with Windows PowerShell

This module will introduce you to Windows PowerShell and provide an overview of the product’s functionality.
The module explains how to open and configure Windows PowerShell. It also explains how to run commands
and use the built-in Help system in Windows PowerShell.

»  Windows PowerShell overview
» Understand Windows PowerShell command syntax
» Find commands and get help in Windows PowerShell

Lab : Configuring Windows PowerShell, and finding and running commands
»  Configuring the Windows PowerShell console application
»  Configuring the Windows PowerShell ISE application
» Finding and running Windows PowerShell commands
»  Using About files

After completing module 1, students will be able to:
» Describe key features of Windows PowerShell, and open and configure it.
» Discover, learn, and run Windows PowerShell commands.
»  Find Windows PowerShell commands for performing specific tasks.

Module 2: Windows PowerShell for Local Systems Administration

This module introduces you to the different types of cmdlets commonly used for system administration. While
you can search for cmdlets each time you need to accomplish a task, it is more efficient to have at least a
basic understanding of these cmdlets. This module also explains how to manage Windows 10 by using
PowerShell.

»  Active Directory Domain Services administration cmdlets
»  Network configuration cmdlets

»  Server administration cmdlets

»  Windows PowerShell in Windows 10

Lab : Performing local system administration with PowerShell
» Creating and managing Active Directory objects
»  Configuring network settings on Windows Server
» Creating a website

After completing module 2, students will be able to:
» Identify and use cmdlets for AD DS administration.
» Identify and use cmdlets for network configuration.
» Identify and use cmdlets for server administration tasks.
» Manage Windows 10 using PowerShell
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Module 3: Working with the Windows PowerShell Pipeline

This module introduces the pipeline feature of Windows PowerShell. The pipeline feature is included in
several command-line shells such as the command prompt in the Windows operating system. However, the
pipeline feature in Windows PowerShell provides more complex, flexible, and capable functionalities
compared to other shells. This module provides you with the skills and knowledge that will help you use
Windows PowerShell more effectively and efficiently.

Understand the pipeline

Select, sort, and measure objects
Filter objects out of the pipeline
Enumerate objects in the pipeline
Send and pass pipeline data as output

FFIFFF

Lab : Using PowerShell pipeline
»  Selecting, sorting, and displaying data
»  Filtering objects
» Enumerating objects
» Converting objects

After completing module 3, students will be able to:

Describe the purpose of the Windows PowerShell pipeline.
Select, sort, and measure objects in the pipeline.

Filter objects out of the pipeline.

Enumerate objects in the pipeline.

Send output consisting of pipeline data.

FFIFFYF

Module 4: Using PSProviders and PSDrives

This module introduces the PSProviders and PSDrives adapters. A PSProvider is basically a Windows
PowerShell adapter makes some form of storage resemble a hard drive. A PSDrive is an actual connection to
a form of storage. You can use these two technologies to work with various forms of storage by using the
same commands and techniques that you use to manage the file system.

»  Using PSProviders
» Using PSDrives

Lab : Using PSProviders and PSDrives with PowerShell
» Creating files and folders on a remote computer
» Creating a registry key for your future scripts
» Create a new Active Directory group

After completing module 4, students will be able to:

» Use PSProviders.
» Use PSDrives.
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Module 5: Querying Management Information by using CIM and WMI

This module introduces you to two parallel technologies: Windows Management Instrumentation (WMI) and
Common Information Model (CIM). Both these technologies provide local and remote access to a repository
of management information including access to robust information available from the operating system,
computer hardware, and installed software.

» Understand CIM and WMI
»  Query data by using CIM and WMI
» Make changes by using CIM and WMI

Lab : Querying information by using WMI and CIM
»  Querying information by using WMI
»  Querying information by using CIM
» Invoking methods

After completing module 5, students will be able to:
» Differentiate between CIM and WMI.
»  Query management information by using CIM and WMI.
»  Invoke methods by using CIM and WMI.

Module 6: Working with Variables, Arrays and Hash Tables

Variables are an essential component of scripts. You can use variables to accomplish complex tasks that you
can't complete by using a single command. This module explains how to work with variables, arrays, and
hash tables as steps in learning how to create Windows PowerShell scripts.

» Use variables
» Manipulate variables
» Manipulate arrays and hash tables

Lab : Using variables, arrays, and hash tables in PowerShell
»  Working with variable types
» Using arrays
» Using hash tables

After completing module 6, students will be able to:
» Assign a value to variables.
» Describe how to manipulate variables.
» Describe how to manipulate arrays and hash tables.
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Module 7: Windows PowerShell Scripting
This module explains how to package a Windows PowerShell command in a script. Scripts allow you to
perform repetitive tasks and more complex tasks than cannot be accomplished in a single command.

Introduction to scripting with Windows PowerShell

FFIFFYF

Lal

FFIFFFFO

Script constructs

Import data from files

Accept user input

Troubleshooting and error handling
Functions and modules

: Using scripts with PowerShell

Signing a script

Processing an array with a ForEach loop
Processing items by using If statements

Creating users based on a CSV file

Querying disk information from remote computers
Updating the script to use alternate credentials

After completing module 7, students will be able to:

FIFIFIFIFY

Module 8: Administering Remote Computers with Windows PowerShell

Run a Windows PowerShell script.

Use Windows PowerShell scripting constructs.
Import data from a file.

Accept user input for a script.

Implement error handling for a script.

Explain functions and modules.

This module introduces you to the Windows PowerShell remoting technology that enables you to connect to

one or more remote computers and instruct them to run commands on your behalf.

»

» Use advanced Windows PowerShell remoting techniques

»

Use basic Windows PowerShell remoting

Use PSSessions

Lab : Performing remote administration with PowerShell

»
»
»
»

Enabling remoting on the local computer
Performing one-to-one remoting
Performing one-to-many remoting

Using implicit remoting

After completing module 8, students will be able to:

»

» Use advanced Windows PowerShell remoting techniques.

»

Describe remoting architecture and security.

Create and manage persistent remoting sessions.
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Module 9: Managing Azure Resources with PowerShell

This module provides information about installing the necessary modules for cloud services management. It
explains how to use PowerShell commands to perform some simple administrative tasks on cloud resources
such as Azure virtual machines (VMs), Azure storage accounts, and Azure subscriptions. This module also
describes how to use the Azure Cloud Shell environment to perform PowerShell-based or Bash-based
administration directly from the Azure portal.

Azure PowerShell

Introduce Azure Cloud Shell
Manage Azure VMs with PowerShell
Manage storage and subscriptions

FFEFFF

Lab : Azure resource management with PowerShell
»  Activating the Azure subscription and installing the PowerShell Az module
»  Using Azure Cloud Shell
» Managing Azure resources with Azure PowerShell

After completing module 9, students will be able to:
» Describe, install, and use the Azure PowerShell environment
» Describe and use Azure Cloud Shell.
» Manage Azure VMs with PowerShell.
» Manage Azure storage accounts and subscriptions with Azure PowerShell.

Module 10: Managing Microsoft 365 services with PowerShell
This module describes how to use PowerShell to manage Microsoft 365 user accounts, licenses, and groups,
Exchange Online, SharePoint Online, and Microsoft Teams.

Manage Microsoft 365 user accounts, licenses, and groups with PowerShell
Manage Exchange Online with PowerShell

Manage SharePoint Online with PowerShell

Manage Microsoft Teams with PowerShell

FIFFF

Lab : Managing Microsoft 365 with PowerShell
» Managing users and groups in Azure AD
» Managing Exchange Online
» Managing SharePoint
» Managing Microsoft Teams

After completing module 10, students will be able to:
» Use PowerShell to manage users, groups, and licenses in Azure AD
» Manage Exchange Online with PowerShell.
» Manage SharePoint Online with PowerShell.
» Manage Microsoft Teams with PowerShell.
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Module 11: Using Background Jobs and Scheduled Jobs
This module describes how to use background jobs and scheduled jobs. It also explains how to create
scheduled jobs and retrieve job results.

» Use background jobs
» Use scheduled jobs

Lab : Jobs management with PowerShell
»  Starting and managing jobs
» Creating a scheduled job

After completing module 11, students will be able to:
» Create and manage background jobs.
» Create and manage scheduled jobs.

Exam Details
There is no exam directly relating to this course.
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skilltec Microsoft Azure
training Administrator

Moving forward in knowledge and training

Course Code MAZ104
Duration 4 days

Overview

This course teaches IT Professionals how to manage their Azure subscriptions, secure identities, administer
the infrastructure, configure virtual networking, connect Azure and on-premises sites, manage network traffic,
implement storage solutions, create and scale virtual machines, implement web apps and containers, back up
and share data, and monitor your solution.

Audience

This course is for Azure Administrators. The Azure Administrator implements, manages, and monitors
identity, governance, storage, compute, and virtual networks in a cloud environment. The Azure Administrator
will provision, size, monitor, and adjust resources as appropriate.

Learning Objectives
By actively participating in this course, you will learn about the following:

Managing Azure identities and governance.
Implementing and managing storage.

Deploying and managing Azure compute resources.
Configuring and managing virtual networking.
Monitoring and backing up Azure resources.

FIEFFF ¥

Pre-Requisites

» Understanding of on-premises virtualization technologies, including: VMs, virtual networking, and
virtual hard disks.

» Understanding of network configurations, including TCP/IP, Domain Name System (DNS), virtual
private networks (VPNSs), firewalls, and encryption technologies.

» Understanding of Active Directory concepts, including users, groups, and role-based access control.

» Understanding of resilience and disaster recovery, including backup and restore operations.
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Course Contents

Module 1: Identity
In this module, you will learn how to secure identities with Azure Active Directory and implement users and
groups.

Lessons

»
»

Azure Active Directory
Users and Groups

Lab: Manage Azure Active Directory Identities

»
»
»

After completing this module, delegates will be able to:
Secure and manage identities with Azure Active Directory.
Implement and manage users and groups.

Module 2: Governance and Compliance
In this module, you will learn about managing your subscriptions and accounts, implementing Azure policies,
and using Role-Based Access Control.

Lessons

»
»
»

Labs
»
»

Subscriptions and Accounts
Azure Policy
Role-based Access Control (RBAC)

Manage Subscriptions and RBAC
Manage Governance via Azure Policy

After completing this module, delegates will be able to:

»
»
»

Implement and manage Azure subscriptions and accounts.
Implement Azure Policy, including custom policies.
Use RBAC to assign permissions.

Module 3: Azure Administration
In this module, you will learn about the tools an Azure Administrator uses to manage their infrastructure. This
includes the Azure Portal, Cloud Shell, Azure PowerShell, CLI, and Resource Manager Templates. This

module includes:

Lessons

FFF ¥

Labs

FFF ¥

Azure Resource Manager
Azure Portal and Cloud Shell
Azure PowerShell and CLI
ARM Templates

Manage Azure resources by Using the Azure Portal

Manage Azure resources by Using ARM Templates

Manage Azure resources by Using Azure PowerShell (optional)
Manage Azure resources by Using Azure CLI (optional)

After completing this module, delegates will be able to:

FF¥FFF

Leverage Azure Resource Manager to organize resources.
Use the Azure Portal and Cloud Shell.

Use Azure PowerShell and CLI.

Use ARM Templates to deploy resources.
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Module 4: Virtual Networking
In this module, you will learn about basic virtual networking concepts like virtual networks and subnetting, IP
addressing, network security groups, Azure Firewall, and Azure DNS.

Lessons

Virtual Networks

IP Addressing

Network Security groups
Azure Firewall

Azure DNS

FFIFFYF

Lab: Implement Virtual Networking

After completing this module, delegates will be able to:
Implement virtual networks and subnets.

Configure public and private IP addressing.
Configure network security groups.

Configure Azure Firewall.

Configure private and public DNS zones.

FFIFFF

Module 5: Intersite Connectivity
In this module, you will learn about intersite connectivity features including VNet Peering, Virtual Network
Gateways, and Site-to-Site Connections.

Lessons
» VNet Peering
» VPN Gateway Connections
» ExpressRoute and Virtual WAN

Lab: Implement Intersite Connectivity

After completing this module, delegates will be able to:
» Configure VNet Peering.
» Configure VPN gateways.
» Choose the appropriate intersite connectivity solution.

Module 6: Network Traffic Management
In this module, you will learn about network traffic strategies including network routing and service endpoints,
Azure Load Balancer, and Azure Application Gateway.

Lessons
»  Network Routing and Endpoints
» Azure Load Balancer
»  Azure Application Gateway

Lab: Implement Traffic Management
After completing this module, delegates will be able to:
»  Configure network routing including custom routes and service endpoints.

» Configure an Azure Load Balancer.
»  Configure and Azure Application Gateway.
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Module 7: Azure Storage
In this module, you will learn about basic storage features including storage accounts, blob storage, Azure

files and File Sync, storage security, and storage tools.
Lessons

» Storage Accounts

» Blob Storage

» Storage Security

» Azure Files and File Sync

» Managing Storage
Lab: Manage Azure storage

After completing this module, delegates will be able to:

FFIFFF

Create Azure storage accounts.

Configure blob containers.

Secure Azure storage.

Configure Azure files shares and file sync.

Manage storage with tools such as Storage Explorer.

Module 8: Azure Virtual Machines
In this module, you will learn about Azure virtual machines including planning, creating, availability and

exte

nsions.

Lessons

»
»
»
»

Lab

Virtual Machine Planning
Creating Virtual Machines
Virtual Machine Availability
Virtual Machine Extensions

: Manage virtual machines

After completing this module, delegates will be able to:

FIFEFFY

Plan for virtual machine implementations.
Create virtual machines.

Configure virtual machine availability, including scale sets.

Use virtual machine extensions.
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Module 9: Serverless Computing
In this module, you will learn how to administer serverless computing features like Azure App Service, Azure
Container Instances, and Kubernetes.

Lessons

Azure App Service Plans
Azure App Service
Container Services

Azure Kubernetes Service

FFF ¥

Labs
» Implement Web Apps
» Implement Azure Container Instances
» Implement Azure Kubernetes Service

After completing this module, delegates will be able to:
» Create an app service plan.
» Create a web app.
» Implement Azure Container Instances.
» Implement Azure Kubernetes Service.

Module 10: Data Protection
In this module, you will learn about backing up files and folders, and virtual machine backups.

Lessons
» File and Folder Backups
»  Virtual Machine Backups

Lab: Implement Data Protection

After completing this module, delegates will be able to:
» Backup and restore file and folders.
» Backup and restore virtual machines.

Module 11: Monitoring
In this module, you will learn about monitoring your Azure infrastructure including Azure Monitor, alerting, and
log analytics.

Lessons
»  Azure Monitor
» Azure Alerts
» Log Analytics
» Network Watcher

Lab: Implement Monitoring

After completing this module, delegates will be able to:
» Use Azure Monitor.
» Create Azure alerts.
»  Query using Log Analytics.
»  Use Network Watcher.

Exam Details
This course leads to the AZ-104 Microsoft Azure Administrator exam, which will earn you the
Microsoft Certified: Azure Administrator Associate certification.
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skilltec Planning & Administering
training Microsoft Azure for SAP

Moving forward in knowledge and training WO r kl O ad S
Course Code MAZ120
Duration 4 days
Overview

This course teaches IT Professionals experienced in SAP solutions how to leverage Azure resources that
include deployment and configuration of virtual machines, virtual networks, storage accounts, and Azure AD
that includes implementing and managing hybrid identities. Students of this course will learn through
concepts, scenarios, procedures, and hands-on labs how to best plan and implement migration and operation
of an SAP solution on Azure. Your will receive guidance on subscriptions, create and scale virtual machines,
implement storage solutions, configure virtual networking, back up and share data, connect Azure and on-
premises sites, manage network traffic, implement Azure Active Directory, secure identities, and monitor your
solution.

Audience

This course is for Azure Administrators who migrate and manage SAP solutions on Azure. Azure
Administrators manage the cloud services that span storage, networking, and compute cloud capabilities, with
a deep understanding of each service across the full IT lifecycle. They take end-user requests for new cloud
applications and make recommendations on services to use for optimal performance and scale, as well as
provision, size, monitor and adjust as appropriate. This role requires communicating and coordinating with
vendors. Azure Administrators use the Azure Portal and as they become more proficient, they use PowerShell
and the Command Line Interface.

Learning Objectives
By actively participating in this course, you will learn about the following:

» Migrate and manage SAP applications (SAP HANA, S/4AHANA, SAP NetWeaver) on Azure

» Leverage Azure Portal, Cloud Shell, Azure PowerShell, CLI, Resource Manager, and Resource
Manager Te

» Use intersite connectivity features including VNet Peering, VNet-to-VNet connections, Site-to-Site C

»  Work with Azure Active Directory (AD), Azure AD Connect, and Azure AD Join, and Azure AD Identity
Pro

Pre-Requisites

»  Administrators and architects of Azure solutions for SAP should possess solid knowledge of SAP
Applications, SAP HANA, S/4AHANA, SAP NetWeaver, SAP BW, OS Servers for SAP Applications and
Databases.

»  Prior to taking this course, it is recommended that students have taken the Microsoft Azure
Administrator (MAZ-104) training, as well as SAP HANA and Linux training.
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Course Contents

Module 1: Introduction
Contains an overview of the SAP and Microsoft partnership.

Module 2: Foundations of SAP on Azure
Contains brief lessons on:

FFIFIFIFIFIFTFY

Azure Compute

Azure Storage

Azure Networking

SAP HANA on Azure (Large Instances)
Identity services

Governance and manageability

Backup and data protection services
Resiliency and increased availability services
Migration Services

Module 3: SAP Certified Offerings on Azure
Contains lessons on:

FIFIFIFIFIFIFFY

General prerequisites (SAP support in public cloud environments)
Deployment options of SAP solutions on Azure

SAP product-specific support on Azure

Operating System support for SAP on Azure

Storage support for SAP on Azure

Networking support for SAP on Azure

Database support for SAP on Azure

High availability and disaster recovery support for SAP on Azure
Monitoring requirements for SAP on Azure

Lab: Online Lab: Implementing Linux clustering on Azure VMs
Lab: Online Lab: Implementing Windows clustering on Azure VMs

Module 4: SAP on Azure Reference Architecture
Contains lessons on:

»
»
»

SAP NetWeaver with AnyDB on Azure VMs
SAP S4 HANA on Azure VMs
SAP HANA on Azure (Large Instances)

Module 5: Planning for Implementing SAP Solutions on Azure
Contains lessons on:

FIFIFIFIFIFIFIFIFY

Azure VM compute, network, and storage considerations

Azure VM high availability and disaster recovery

Azure VM backup considerations

Azure VM monitoring considerations

Azure VM security considerations

Azure VM authentication and access control considerations

SAP HANA on Azure (Large Instances) compute, network, and storage
SAP HANA on Azure (Large Instances) HA and DR considerations
SAP HANA on Azure (Large Instances) backup considerations

SAP HANA on Azure (Large Instances) security

Module 6: Planning for Migrating SAP Workloads to Azure
Contains lessons on:

»
»

Strategies for migrating SAP systems to Microsoft Azure
SAP workload planning and deployment checklist

Page 20 of 75



Module 7: Implementing Azure VM-based SAP Solutions
Contains lessons on:

Azure VM deployment methodologies

Single-instance implementations (2-tier or 3-tier)
Implementing HA SAP NetWeaver with AnyDB on Azure VMs
Implementing HA SAP HANA on Azure VMs

Configure the Azure Enhanced Monitoring Extension for SAP
Implementing AD and Azure AD-based authentication

FIFIFIFFT

Module 8: Module 8-Deploying HANA Large Instances (HLI)
Contains a lesson on:
» Implementing HANA Large Instances

Module 9: Migrating SAP Workloads to Azure
Contains lessons on:

»  Migration options

» DMO Methodology

» Cloud migration options

» Very Large Database Migration to Azure

Lab: Online Lab-Implement SAP architecture on Azure VMs running Linux
Lab: Online Lab-Implement SAP architecture on Azure VMs running Windows

Module 10: Maintaining SAP on Azure
Contains lessons on:

Remote management

Performing backups and restores
Networking changes

OS and workload updates
Vertical and horizontal scaling
Disaster Recovery

FIFIFIFIFY

Module 11: Monitoring and Troubleshooting SAP on Azure
Contains lessons on:

»  Monitoring Azure VMs

»  Monitoring SAP HANA on Azure (Large Instances)

» Integrating SAP solutions with Microsoft cloud services

Exam Details
This course helps you to prepare for exam AZ-120
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skilltec Configuring and
train]'ng Operating Azure Virtual

Moving forward in knowledge and training D eS kto p

Course Code MAZ140
Duration 4 days

Overview

This course teaches Azure administrators how to plan, deliver, and manage virtual desktop experiences and
remote apps, for any device, on Azure. Students will learn through a mix of demonstrations and hands-on lab
experiences deploying virtual desktop experiences and apps on Windows Virtual Desktop and optimizing
them to run in multi-session virtual environments.

Audience

Students for AZ-140: Configuring and Operating Windows Virtual Desktop on Microsoft Azure are interested
in delivering applications on Windows Virtual Desktop and optimizing them to run in multi-session virtual
environments. As a Windows Virtual Desktop administrator, you will closely with the Azure Administrators and
Architects, along with Microsoft 365 Administrators. Windows Virtual Desktop administrator responsibilities
include planning, deploying, packaging, updating, and maintaining the Azure Windows Virtual Desktop
infrastructure. They also create session host images, implement and manage FSLogix, monitor Windows
Virtual Desktop performance, and automate Windows Virtual Desktop management tasks.

Learning Objectives
By actively participating in this course, you will learn about the following:

Select an appropriate licensing model for Windows Virtual Desktop

Implement networking for Windows Virtual Desktop

Manage Windows Virtual Desktop session hosts by using Azure Bastion

Configure storage for FSLogix components

Create and manage session host images

Implement Azure roles and role-based access control (RBAC) for Windows Virtual Desktop
Configure user Windows Virtual Desktop experience settings

Install and configure apps on a session host

Implement business continuity and disaster recovery

Monitor and manage Windows Virtual Desktop performance

FIFIFTIFIFIFIFTIFTFY

Pre-Requisites

There are no specific pre-requisites for this course.
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Course Contents

Module 1: Plan a Windows Virtual Desktop Architecture

In this module, you will learn how to assess existing physical and virtual desktop environments, plan and
configure name resolution for Active Directory (AD) and Azure Active Directory Domain Services (Azure AD
DS), and plan for Windows Virtual Desktop client deployments.

Lessons M1
»  Windows Virtual Desktop Architecture
» Design the WVD architecture
» Design for user identities and profiles

Lab: Prepare for deployment of Azure Windows Virtual Desktop (Azure AD DS)
Lab: Prepare for deployment of Azure Windows Virtual Desktop (AD DS)

After completing module 1, students will be able to:
» Understand Windows Virtual Desktop Components
» Understand personal and pooled desktops
» Recommend an operating system for a WVD implementation
» Plan a host pools architecture

Module 2: Implement a WVD Infrastructure

In this module, you will learn how to manage connectivity to the internet and on-premises networks, create a
host pool by using the Azure portal, deploy host pools and hosts by using Azure Resource Manager
templates, apply OS and application updates to a running WVD host, and create a master image.

Lessons M2
» Implement and manage networking for WVD
» Implement and manage storage for WVD
» Create and configure host pools and session hosts
» Create and manage session host image

Lab: Create and configure host pools and session hosts (Azure AD DS)

Lab: Deploy host pools and session hosts by using the Azure portal (AD DS)
Lab: Implement and manage storage for WVD (Azure AD DS)

Lab: Deploy host pools and hosts by using Azure Resource Manager templates
Lab: Deploy and manage host pools and hosts by using PowerShell

After completing module 2, students will be able to:

Implement Azure virtual network connectivity

Manage connectivity to the internet and on-premises networks
Understanding Windows Virtual Desktop network connectivity
Configure WVD session hosts using Azure Bastion

Configure storage for FSLogix components

Configure disks and file shares

Modify a session host image

Create and use a Shared Image Gallery (SIG)

FIFIFIFIFIFIFY
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Module 3: Manage Access and Security

In this module, you will learn how to plan and implement Azure roles and RBAC for WVD, implement
Conditional Access policies for connections, plan and implement MFA, and manage security by using Azure
Security Center.

Lessons M3
» Manage access
» Manage security

Lab: Configure Conditional Access policies for connections to WVD (AD DS)

After completing module 3, students will be able to:

Manage local roles, groups and rights assignment on WVD session hosts.

Configure user restrictions by using AD group policies and Azure AD policies

Understand Conditional Access policy components

Prepare for Azure Active Directory (Azure AD)-based Conditional Access for Windows Virtual Desktop
Implement Azure AD-based Conditional Access for Windows Virtual Desktop

FFIFF¥

Module 4: Manage User Environments and Apps

In this module, you will learn how to plan for FSLogix, install FSLogix, configure Cloud Cache, deploy an
application as a RemoteApp, and implement and manage OneDrive for Business for a multi-session
environment.

Lessons M4
» Implement and manage FSLogix
» Configure user experience settings
» Install and configure apps on a session host

Lab: Windows Virtual Desktop profile management (Azure AD DS)
Lab: Windows Virtual Desktop profile management (AD DS)
Lab: Windows Virtual Desktop application packaging (AD DS)

After completing module 4, students will be able to:

Configure Profile Containers

Configure Azure Files to store profile containers for WVD in an AAD DS environment
Implement FSLogix based profiles for Windows Virtual Desktop in Azure AD DS environment
Implement FSLogix based profiles for Windows Virtual Desktop

Prepare for and create MSIX app packages

Implement MSIX app attach container for Windows Virtual Desktop in AD DS environment

FIFIFIFFF
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Module 5: Monitor and Maintain a WVD Infrastructure

In this module, you will learn how to plan and implement a disaster recovery plan for WVD, configure
automation for WVD, implement autoscaling in host pools, and optimize session host capacity and
performance.

Lessons M5
» Plan and implement business continuity and disaster recovery
» Automate WVD management tasks
»  Monitor and manage performance and health

Lab: Implement autoscaling in host pools (AD DS)

After completing module 5, students will be able to:

Plan and implement a disaster recovery plan for WVD

Configure automation for WVD

Monitor WVD by using Azure Monitor

Customize Azure Workbooks for WVD monitoring

Configure autoscaling of Windows Virtual Desktop session hosts
Verify autoscaling of Windows Virtual Desktop session host

FIFIFIFFT

Exam Details
This course is preparation for the Microsoft Exam AZ-140.
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skilltec Developing Solutions for
training Microsoft Azure

Moving forward in knowledge and training

Course Code MAZ204
Duration 5 days

Overview

This course teaches developers how to create end-to-end solutions in Microsoft Azure. Delegates will learn
how to implement Azure compute solutions, create Azure Functions, implement and manage web apps,
develop solutions utilizing Azure storage, implement authentication and authorization, and secure their
solutions by using KeyVault and Managed Identities. Delegates will also learn how to connect to and
consume Azure services and third-party services and include event- and message-based models in their
solutions. The course also covers monitoring, troubleshooting, and optimizing Azure solutions.

Audience
Delegates in this course are interested in Azure development or in passing the Microsoft Azure Developer
Associate certification exam.

Learning Objectives
By actively participating in this course, you will learn about the following:

Developing Azure compute solutions.

Developing for Azure storage.

Implementing Azure security.

Monitoring, troubleshooting, and optimizing Azure solutions.
Connecting to and consuming Azure services and third-party services.

FFEFIFIFY

Pre-Requisites
Delegates should have 1-2 years’ professional development experience and experience with Microsoft Azure.
They must be able to program in an Azure Supported Language.
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Course Contents

Module 1: Creating Azure App Service Web Apps
Delegates will learn how to build a web application on the Azure App Service platform. They will learn how the
platform functions and how to create, configure, scale, secure, and deploy to the App Service platform.

Lessons

Azure App Service core concepts

Creating an Azure App Service Web App
Configuring and Monitoring App Service apps
Scaling App Service apps

Azure App Service staging environments

FFIFFF

Module 2: Implement Azure functions
This module covers creating Functions apps, and how to integrate triggers and inputs/outputs into the app.

Lessons
»  Azure Functions overview
» Developing Azure Functions
» Implement Durable Functions

Module 3: Develop solutions that use blob storage
Delegates will learn how Azure Blob storage works, how to manage data through the hot/cold/archive blob
storage lifecycle, and how to use the Azure Blob storage client library to manage data and metadata.

Lessons
»  Azure Blob storage core concepts
» Managing the Azure Blob storage lifecycle
»  Working with Azure Blob storage

Module 4: Develop solutions that use Cosmos DB storage

Delegates will learn how Cosmos DB is structured and how data consistency is managed. Delegates will also
learn how to create Cosmos DB accounts and create databases, containers, and items by using a mix of the
Azure Portal and the .NET SDK.

Lessons
» Azure Cosmos DB overview
» Azure Cosmos DB data structure
»  Working with Azure Cosmos DB resources and data

Module 5: Implement laaS solutions

This module instructs delegates on how to use create VMs and container images to use in their solutions. It
covers creating VMs, using ARM templates to automate resource deployment, create and manage Docker
images, publishing an image to the Azure Container Registry, and running a container in Azure Container
Instances.

Lessons

Provisioning VMs in Azure

Create and deploy ARM templates

Create container images for solutions

Publish a container image to Azure Container Registry

Create and run container images in Azure Container Instances

FFIFFF
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Module 6: Implement user authentication and authorization

Delegates will learn how to leverage the Microsoft Identity Platform v2.0 to manage authentication and access
to resources. Delegates will also learn how to use the Microsoft Authentication Library and Microsoft Graph to
authenticate a user and retrieve information stored in Azure, and how and when to use Shared Access
Signatures.

Lessons
»  Microsoft Identity Platform v2.0
»  Authentication using the Microsoft Authentication Library
»  Using Microsoft Graph
»  Authorizing data operations in Azure Storage

Module 7: Implement secure cloud solutions
This module covers how to secure the information (keys, secrets, certificates) an application uses to access
resources. It also covers securing application configuration information.

Lessons
» Manage keys, secrets, and certificates by using the KeyVault API
» Implement Managed Identities for Azure resources
»  Secure app configuration data by using Azure App Configuration

Module 8: Implement APl Management
Delegates will learn how to publish APIs, create policies to manage information shared through the API, and
to manage access to their APIs by using the Azure APl Management service.

Lessons
» APl Management overview
»  Defining policies for APIs
»  Securing your APIs

Module 9: Develop App Service Logic Apps
This module teaches delegates how to use Azure Logic Apps to schedule, automate, and orchestrate tasks,
business processes, workflows, and services across enterprises or organizations.

Lessons
»  Azure Logic Apps overview
» Creating custom connectors for Logic Apps

Module 10: Develop event-based solutions
Delegates will learn how to build applications with event-based architectures.

Lessons
» Implement solutions that use Azure Event Grid
» Implement solutions that use Azure Event Hubs
» Implement solutions that use Azure Notification Hubs

Module 11: Develop message-based solutions
Delegates will learn how to build applications with message-based architectures.

Lessons

» Implement solutions that use Azure Service Bus
» Implement solutions that use Azure Queue Storage queues
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Module 12: Monitor and optimize Azure solutions
This module teaches delegates how to instrument their code for telemetry and how to analyze and
troubleshoot their apps.

Lessons
»  Overview of monitoring in Azure
» Instrument an app for monitoring
»  Analyzing and troubleshooting apps
» Implement code that handles transient faults

Module 13: Integrate caching and content delivery within solutions
Delegates will learn how to use different caching services to improve the performance of their apps.

Lessons
» Develop for Azure Cache for Redis
» Develop for storage on CDNs

Exam Details
This course leads to the AZ-204 Developing Solutions for Microsoft Azure exam, which will earn you the
Microsoft Certified: Azure Developer Associate certification.
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skilltec Designing Microsoft
traini ng Azure Infrastructure

Moving forward in knowledge and training S O I u ti O n S
Course Code MAZ305
Duration 4 days
Overview

This course teaches Azure Solution Architects how to design infrastructure solutions. Course topics cover
governance, compute, application architecture, storage, data integration, authentication, networks, business
continuity, and migrations. The course combines lecture with case studies to demonstrate basic architect
design principles.

Audience

Successful students have experience and knowledge in IT operations, including networking, virtualization,
identity, security, business continuity, disaster recovery, data platforms, and governance. Students also have
experience designing and architecting solutions.

Learning Objectives
By actively participating in this course, you will learn about the following:

» Design a governance solution.
» Design a compute solution.
» Design an application architecture

Pre-Requisites
Before attending this course, students must have previous experience deploying or administering Azure
resources and conceptual knowledge of:

Azure Active Directory

Azure compute technologies such as VMs, containers and serverless solutions
Azure virtual networking to include load balancers

Azure Storage technologies (unstructured and databases)

General application design concepts such as messaging and high availability

FFEFIFIFY

Recommended prerequisites: MAZ104 — Microsoft Azure Administrator
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Course Contents

Module 1: Design compute and application solutions
In this module you will learn about governance, compute, and application architectures.

Lessons of Module 1

» Design for governance

» Design for compute solutions

» Design for application architectures

Lab: Case studies of Module 1

» Design a governance solution.

» Design a compute solution.

» Design an application architecture.

Module 2: Design storage solutions
In this module, you will learn about non-relational storage, relational storage, and data integration solutions.

Lessons of Module 2

» Design a non-relational storage solution.
» Design a relational storage solution.

» Design a data integration solution.

Lab: Case studies of Module 2

» Design non-relational storage solutions.
» Design relational storage solutions.

» Design a data integration solution.

Module 3: Design networking and access solutions
In this module you will learn about authentication and authorization, identity and access for applications, and

networking solutions.

Lessons of Module 3
» Design authentication and authorization solutions

» Design networking solutions

Lab: Case studies of Module 3
» Design authentication and authorization solutions.
» Design network solutions.

Module 4: Design business continuity solutions

Lessons of Module 4

» Design for backup and disaster recovery
»  Design monitoring solutions

»  Design for migrations

Lab: Case studies of Module 4

» Design backup and disaster recovery.
»  Design monitoring solutions.

»  Design for migrations

Exam Details
This course leads to the Microsoft Exam AZ-305

Page 31 of 75



skilltec Microsoft Azure DevOps
trainin Engineer - Bootcamp

Moving forward in knowledge and training

Course Code MAZ400
Duration 5 days

Overview

This course provides the knowledge and skills to design and implement DevOps processes and practices.
Delegates will learn how to plan for DevOps, use source control, scale Git for an enterprise, consolidate
artifacts, design a dependency management strategy, manage secrets, implement continuous integration,
implement a container build strategy, design a release strategy, set up a release management workflow,
implement a deployment pattern, and optimize feedback mechanisms.

Audience
Delegates in this course are interested in implementing DevOps processes or in passing the Microsoft Azure
DevOps Solutions certification exam.

Learning Objectives
By actively participating in this course, you will learn about the following:

Planning for the transformation with shared goals and timelines.

Selecting a project and identifying project metrics and KPls.

Creating a team and agile organization structure.

Describing the benefits of using Source Control.

Migrating from TFVC to Git.

Scaling Git for Enterprise DevOps.

Recommending artifact management tools and practices.

Abstract common packages to enable sharing and reuse.

Migrating and consolidating artifacts.

Migrating and integrating source control measures.

Managing application config and secrets.

Developing a project quality strategy.

Planning for secure development practices and compliance rules.
Implementing and managing build infrastructure.

Explaining why continuous integration matters.

Implementing continuous integration using Azure DevOps.

Managing code quality including: technical debt, SonarCloud, and other tooling solutions.
Managing security policies with open source, OWASP, and WhiteSource Bolt.
Implementing a container strategy including how containers are different from virtual machines and
how microservices use containers.

Implementing containers using Docker.

FIFIFIFIFTFIFIFIFIFIFFIFFvyFbvysrsrsy
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standards.

Configuring build pipeline to access package security and license rating.

Configuring secure access to package feeds.

Inspecting codebase to identify code dependencies that can be converted to packages.
Identifying and recommending standardized package types and versions across the solution.
Refactoring existing build pipelines to implement version strategy that publishes packages.
Managing security and compliance.

Differentiating between a release and a deployment.

FFIFIFIFFY

Inspecting open source software packages for security and license compliance to align with corporate
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Defining the components of a release pipeline.

Explaining things to consider when designing your release strategy.

Classifying a release versus a release process and outlining how to control the quality of both.
Describing the principle of release gates and how to deal with release notes and documentation.
Explaining deployment patterns, both in the traditional sense and in the modern sense.
Choosing a release management tool.

Explaining the terminology used in Azure DevOps and other Release Management Tooling.
Describing what a Build and Release task is, what it can do, and some available deployment tasks.
Classifying an Agent, Agent Queue, and Agent Pool.

Explaining why you sometimes need multiple release jobs in one release pipeline.

Differentiating between multi-agent and multi-configuration release job.

Using release variables and stage variables in your release pipeline.

Deploying to an environment securely using a service connection.

Embedding testing in the pipeline.

Listing the different ways to inspect the health of your pipeline and release by using alerts, service
hooks, and reports.

Creating a release gate.

Describing deployment patterns.

Implementing Blue Green Deployment.

Implementing Canary Release.

Implementing Progressive Exposure Deployment.

Configuring crash report integration for client applications.

Developing monitoring and status dashboards.

Implementing routing for client application crash report data.

Implementing tools to track system usage, feature usage, and flow.

Integrating and configuring ticketing systems with development team's work management.
Implementing a mobile DevOps strategy.

Applying infrastructure and configuration as code principles.

Deploying and managing infrastructure using Microsoft automation technologies such as ARM
templates, PowerShell, and Azure CLI.

Describing deployment models and services that are available with Azure.

Deploying and configuring a Managed Kubernetes cluster.

Deploying and configuring infrastructure using 3rd party tools and services with Azure, such as Chef,
Puppet, Ansible, SaltStack, and Terraform.

Defining an infrastructure and configuration strategy and appropriate toolset for a release pipeline and
application infrastructure.

Implementing compliance and security in your application infrastructure.

Designing practices to measure end-user satisfaction.

Designing processes to capture and analyze user feedback from external sources.

Designing routing for client application crash report data.

Recommending monitoring tools and technologies.

Recommending system and feature usage tracking tools.

Analyzing alerts to establish a baseline.

Analyzing telemetry to establish a baseline.

Performing live site reviews and capturing feedback for system outages.

Performing ongoing tuning to reduce meaningless or non-actionable alerts.

FIFIFFIFIFIFIFIFIFIFIFIFIFY
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Pre-Requisites
Fundamental knowledge about Azure, version control, Agile software development, and core software
development principles. It would be helpful to have experience in an organization that delivers software.
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Course Contents

Module 1: Planning for DevOps
»  Transformation Planning
» Project Selection
» Team Structures
» Migrating to Azure DevOps

Lab: Agile Planning and Portfolio Management with Azure Boards

After completing this module, delegates will be able to:

Plan for the transformation with shared goals and timelines.

Select a project and identify project metrics and KPIs.

Create a team and agile organizational structure.

Design a tool integration strategy.

Design a license management strategy (e.g. VSTS users).

Design a strategy for end-to-end traceability from work items to working software.
Design an authentication and access strategy.

Design a strategy for integrating on-premises and cloud resources.

FFIFIFIFIFFY

Module 2: Getting started with Source Control

What is Source Control

Benefits of Source Control

Types of Source Control Systems

Introduction to Azure Repos

Introduction to GitHub

Migrating from Team Foundation Version Control (TFVC) to Git in Azure Repos
Authenticating to Git in Azure Repos

FFIFIFIFIFY

Lab: Version Controlling with Git

After completing this module, delegates will be able to:
» Describe the benefits of using Source Control.
» Describe Azure Repos and GitHub.
» Migrate from TFVC to Git.

Module 3: Scaling Git for enterprise DevOps

How to Structure your Git Repo

Git Branching Workflows

Collaborating with Pull Requests in Azure Repos
Why care about GitHooks

Fostering Inner Source

FFIFFF

Lab: Code Review with Pull Requests

After completing this module, delegates will be able to:
Explain how to structure Git repos.

Describe Git branching workflows.

Leverage pull requests for collaboration and code reviews.
Leverage Git hooks for automation.

Use git to foster inner source across the organization.

FFIFF¥
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Module 4: Consolidating Artifacts & Designing a Dependency Management Strategy
» Packaging Dependencies
» Package Management
» Migrating and Consolidating Artifacts

Lab: Updating Packages

After completing this module, delegates will be able to:
» Recommend artifact management tools and practices.
»  Abstract common packages to enable sharing and reuse.
» Migrate and consolidate artifacts.
» Migrate and integrate source control measures.

Module 5: Implementing Continuous Integration with Azure Pipelines
The concept of pipelines in DevOps

Azure Pipelines

Evaluate use of Hosted vs Private Agents

Agent Pools

Pipelines and Concurrency

Azure DevOps and Open Source Projects (Public Projects)
Azure Pipelines YAML vs Visual Designer

Continuous Integration Overview

Implementing a Build Strategy

Integration with Azure Pipelines

Integrate External Source Control with Azure Pipelines

Set Up Private Agents

Analyze and Integrate Docker Multi-Stage Builds

FIFIFFIFIFIFIFIFIFIFIFY

Labs
» Enabling Continuous Integration with Azure Pipelines
» Integrating External Source Control with Azure Pipelines

After completing this module, delegates will be able to:
» Implement and manage build infrastructure.
» Explain why continuous integration matters.
» Implement continuous integration using Azure DevOps.

Module 6: Managing Application Config and Secrets

Introduction to Security

Implement secure and compliant development process

Rethinking application config data

Manage secrets, tokens, and certificates

Implement tools for managing security and compliance in a pipeline

FFIFFF

Lab: Integrating Azure Key Vault with Azure DevOps

After completing this module, delegates will be able to:
» Manage application config and secrets.
» Implement tools for managing security and compliance in pipeline.
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Module 7: Managing Code Quality and Security Policies
» Managing Code Quality
» Managing Security Policies

Lab: Managing Technical Debt with Azure DevOps and SonarCloud

After completing this module, delegates will be able to:
» Manage code quality including: technical debt SonarCloud, and other tooling solutions.
» Manage security policies with open source and OWASP.

Module 8: Implementing a Container Build Strategy
» Implementing a Container Build Strategy

Lab: Modernizing Existing ASP.NET Apps with Azure

After completing this module, delegates will be able to:
» Implement a container strategy including how containers are different from virtual machines and how
microservices use containers.
» Implement containers using Docker.

Module 9: Manage Artifact versioning, security & compliance
» Package security
»  Open source software
» Integrating license and vulnerability scans
» Implement a versioning strategy

Lab: Manage Open Source Security and License with WhiteSource

After completing this module, delegates will be able to:
» Inspect open source software packages for security and license compliance to align with corporate
standards.
Configure build pipeline to access package security and license rating.
Configure secure access to package feeds.
Inspect codebase to identify code dependencies that can be converted to packages.
Identify and recommend standardized package types and versions across the solution.
Refactor existing build pipelines to implement version strategy that publishes packages.
Manage security and compliance.

FIFIFIFIFF

Module 10: Design a Release Strategy
Introduction to Continuous Delivery

Release strategy recommendations

Building a High-Quality Release pipeline
Choosing a deployment pattern

Choosing the right release management tool

FFIFF¥

After completing this module, delegates will be able to:

Differentiate between a release and a deployment.

Define the components of a release pipeline.

Explain things to consider when designing your release strategy.

Classify a release versus a release process and outline how to control the quality of both.
Describe the principle of release gates and how to deal with release notes and documentation.
Explain deployment patterns, both in the traditional sense and in the modern sense.

Choose a release management tool.

FFIFIFIFFY
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Module 11: Set up a Release Management Workflow

Create a Release Pipeline

Provision and Configure Environments

Manage and Modularize Tasks and Templates

Integrate Secrets with the release pipeline

Configure Automated Integration and Functional Test Automation
Automate Inspection of Health

FFIFIFFY

Labs

Configuring Pipelines as Code with YAML

Setting up secrets in the pipeline with Azure Key vault
Setting up and Running Functional Tests

Using Azure Monitor as release gate

Creating a release Dashboard

FFIFF¥

After completing this module, delegates will be able to:

Explain the terminology used in Azure DevOps and other Release Management Tooling.
Describe what a Build and Release task is, what it can do, and some available deployment tasks.
Classify an Agent, Agent Queue, and Agent Pool.

Explain why you sometimes need multiple release jobs in one release pipeline.

Differentiate between multi-agent and multi-configuration release job.

Use release variables and stage variables in your release pipeline.

Deploy to an environment securely using a service connection.

Embed testing in the pipeline.

List the different ways to inspect the health of your pipeline and release by using alerts, service hooks,
and reports.

Create a release gate.

FIFIFIFIFIFIFTFY

¥

Module 12: Implement an appropriate deployment pattern
Introduction to Deployment Patterns

Implement Blue Green Deployment

Feature Toggles

Canary Releases

Dark Launching

AB Testing

Progressive Exposure Deployment

FFIFIFIFFY

Lab: Feature Flag Management with Launch Darkly and Azure DevOps

After completing this module, delegates will be able to:
» Describe deployment patterns.
» Implement Blue Green Deployment.
» Implement Canary Release.
» Implement Progressive Exposure Deployment.
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Module 13: Implement process for routing system feedback to development teams
» Implement Tools to Track System Usage, Feature Usage, and Flow
» Implement Routing for Mobile Application Crash Report Data
» Develop Monitoring and Status Dashboards
» Integrate and Configure Ticketing Systems

Lab: Monitoring Application Performance

After completing this module, delegates will be able to:

Configure crash report integration for client applications.

Develop monitoring and status dashboards.

Implement routing for client application crash report data.

Implement tools to track system usage, feature usage, and flow.

Integrate and configure ticketing systems with development team's work management.

FFIFF¥

Module 14: Infrastructure and Configuration Azure Tools
Infrastructure as Code and Configuration Management
Create Azure Resources using ARM Templates
Create Azure Resources using Azure CLI

Create Azure Resources by using Azure PowerShell
Desired State Configuration (DSC)

Azure Automation with DevOps

Additional Automation Tools

FFIFIFIFTFY

Lab: Azure Deployments using Resource Manager Templates

After completing this module, delegates will be able to:
»  Apply infrastructure and configuration as code principles.
» Deploy and manage infrastructure using Microsoft automation technologies such as ARM templates,
PowerShell, and Azure CLI.

Module 15: Azure Deployment Models and Services
Deployment Modules and Options

Azure Infrastructure-as-a-Service (laaS) Services
Azure Platform-as-a-Service (PaaS) services
Serverless and HPC Computer Services

Azure Service Fabric

FIFIFFF

Lab: Deploying a Dockerized Java app to Azure Web App for Containers

After completing this module, delegates will be able to:
» Describe deployment models and services that are available with Azure.

Module 16: Create and Manage Kubernetes Service Infrastructure
»  Azure Kubernetes Service

Lab: Deploying a multi-container application to Azure Kubernetes Service

After completing this module, delegates will be able to:
» Deploy and configure a Managed Kubernetes cluster.
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Module 17: Third Party Infrastructure as Code Tools available with Azure

» Chef

»  Puppet

» Ansible

» Terraform
Labs

» Infrastructure as Code
»  Automating Your Infrastructure Deployments in the Cloud with Terraform and Azure Pipelines

After completing this module, delegates will be able to:
» Deploy and configure infrastructure using 3rd party tools and services with Azure, such as Chef,
Puppet, Ansible, and Terraform.

Module 18: Implement Compliance and Security in your Infrastructure
»  Security and Compliance Principles with DevOps
»  Azure security Center

Lab: Implement Security and Compliance in an Azure DevOps Pipeline

After completing this module, delegates will be able to:
» Define an infrastructure and configuration strategy and appropriate toolset for a release pipeline and
application infrastructure.
» Implement compliance and security in your application infrastructure.

Module 19: Recommend and design system feedback mechanisms
The inner loop

Continuous Experimentation mindset

Design practices to measure end-user satisfaction

Design processes to capture and analyze user feedback

Design process to automate application analytics

FFIFFF

Lab: Integration between Azure DevOps and Teams

After completing this module, delegates will be able to:

Design practices to measure end-user satisfaction.

Design processes to capture and analyze user feedback from external sources.
Design routing for client application crash report data.

Recommend monitoring tools and technologies.

Recommend system and feature usage tracking tools.

FFIFFYF
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Module 20: Optimize feedback mechanisms

Site Reliability Engineering

Analyze telemetry to establish a baseline

Perform ongoing tuning to reduce meaningless or non-actionable alerts
Analyze alerts to establish a baseline

Blameless Retrospectives and a Just Culture

FFIFFF

After completing this module, delegates will be able to:
» Analyze alerts to establish a baseline.
» Analyze telemetry to establish a baseline.
» Perform live site reviews and capture feedback for system outages.
» Perform ongoing tuning to reduce meaningless or non-actionable alerts.

Exam Details
This course leads to the AZ-400 Designing and Implementing Microsoft DevOps Solutions exam, which will
earn you the Microsoft Certified: DevOps Engineer Expert certification.
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skilltec Microsoft Azure Security
trainin Technologies

Moving forward in knowledge and training

Course Code MAZ500
Duration 4 days

Overview

This course provides IT Security Professionals with the knowledge and skills needed to implement security
controls, maintain an organization’s security posture, and identify and remediate security vulnerabilities. This
course includes security for identity and access, platform protection, data and applications, and security
operations.

Audience

This course is for Azure Security Engineers who are planning to take the associated certification exam, or
who are performing security tasks in their day-to-day job. This course would also be helpful to an engineer
that wants to specialize in providing security for Azure-based digital platforms and play an integral role in
protecting an organization's data.

Learning Objectives
By actively participating in this course, you will learn about the following:

» Implementing enterprise governance strategies including role-based access control, Azure policies,
and resource locks.

» Implementing an Azure AD infrastructure including users, groups, and multi-factor authentication.

» Implementing Azure AD Identity Protection including risk policies, conditional access, and access
reviews.

» Implementing Azure AD Privileged Identity Management including Azure AD roles and Azure
resources.

» Implementing Azure AD Connect including authentication methods and on-premises directory
synchronization.

» Implementing perimeter security strategies including Azure Firewall.

» Implementing network security strategies including Network Security Groups and Application Security
Groups.

» Implementing host security strategies including endpoint protection, remote access management,
update management, and disk encryption.

» Implementing container security strategies including Azure Container Instances, Azure Container
Registry, and Azure Kubernetes.

» Implementing Azure Key Vault including certificates, keys, and secretes.

» Implementing application security strategies including app registration, managed identities, and
service endpoints.

» Implementing storage security strategies including shared access signatures, blob retention policies,
and Azure Files authentication.

» Implementing database security strategies including authentication, data classification, dynamic data
masking, and always encrypted.

» Implementing Azure Monitor including connected sources, log analytics, and alerts.

» Implementing Azure Security Center including policies, recommendations, and just in time virtual
machine access.

» Implementing Azure Sentinel including workbooks, incidents, and playbooks.
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Pre-Requisites
Successful learners will have prior knowledge and understanding of:

»  Security best practices and industry security requirements such as defense in depth, least privileged

access, role-based access control, multi-factor authentication, shared responsibility, and zero trust
model.

Be familiar with security protocols such as Virtual Private Networks (VPN), Internet Security Protocol
(IPSec), Secure Socket Layer (SSL), disk and data encryption methods.

Have some experience deploying Azure workloads. This course does not cover the basics of Azure
administration, instead the course content builds on that knowledge by adding security specific
information.

Have experience with Windows and Linux operating systems and scripting languages. Course labs
may use PowerShell and the CLI.

Course Contents

Module 1: Manage Identity and Access
This module covers Azure Active Directory, Azure Identity Protection, Enterprise Governance, Azure AD PIM,
and Hybrid Identity.

Lessons

FIFIFIFF

Labs

FIFIFIFIFY

Azure Active Directory

Azure Identity Protection

Enterprise Governance

Azure AD Privileged Identity Management
Hybrid Identity

Role-Based Access Control

Azure Policy

Resource Manager Locks

MFA, Conditional Access and AAD ldentity Protection
Azure AD Privileged Identity Management

Implement Directory Synchronization

After completing this module, delegates will be able to:

¥
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Implement enterprise governance strategies including role-based access control, Azure policies, and
resource locks.

Implement an Azure AD infrastructure including users, groups, and multi-factor authentication.
Implement Azure AD Identity Protection including risk policies, conditional access, and access reviews.
Implement Azure AD Privileged Identity Management including Azure AD roles and Azure resources.
Implement Azure AD Connect including authentication methods and on-premises directory
synchronization.
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Module 2: Implement Platform Protection
This module covers perimeter, network, host, and container security.

Lessons
» Perimeter Security
» Network Security
» Host Security
» Container Security

Labs
» Network Security Groups and Application Security Groups
»  Azure Firewall
» Configuring and Securing ACR and AKS

After completing this module, delegates will be able to:

» Implement perimeter security strategies including Azure Firewall.

» Implement network security strategies including Network Security Groups and Application Security
Groups.

» Implement host security strategies including endpoint protection, remote access management, update
management, and disk encryption.

» Implement container security strategies including Azure Container Instances, Azure Container
Registry, and Azure Kubernetes.

Module 3: Secure Data and Applications
This module covers Azure Key Vault, application security, storage security, and SQL database security.

Lessons

Azure Key Vault
Application Security
Storage Security

SQL Database Security

F¥EFFF

Labs
» Key Vault (Implementing Secure Data by setting up Always Encrypted)
» Securing Azure SQL Database
»  Service Endpoints and Securing Storage

After completing this module, delegates will be able to:

» Implement Azure Key Vault including certificates, keys, and secretes.

» Implement application security strategies including app registration, managed identities, and service
endpoints.

» Implement storage security strategies including shared access signatures, blob retention policies, and
Azure Files authentication.

» Implement database security strategies including authentication, data classification, dynamic data
masking, and always encrypted.
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Module 4: Manage Security Operations
This module covers Azure Monitor, Azure Security Center, and Azure Sentinel.

Lessons
»  Azure Monitor
»  Azure Security Center
» Azure Sentinel

Labs
»  Azure Monitor
»  Azure Security Center
»  Azure Sentinel

After completing this module, delegates will be able to:
» Implement Azure Monitor including connected sources, log analytics, and alerts.
» Implement Azure Security Center including policies, recommendations, and just in time virtual machine
access.
» Implement Azure Sentinel including workbooks, incidents, and playbooks.

Exam Details
This course leads to the AZ-500 exam, which will earn you the Microsoft Azure Security Engineer Associate
certification.
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skilltec Designing and
training Implementing Microsoft

Moving forward in knowledge and training AZ u re N etWO r ki n g
Solutions
Course Code  MAZ700
Duration 3 days
Overview

This course teaches Network Engineers how to design, implement, and maintain Azure networking solutions.
This course covers the process of designing, implementing, and managing core Azure networking
infrastructure, Hybrid Networking connections, load balancing traffic, network routing, private access to Azure
services, network security and monitoring. Learn how to design and implement a secure, reliable, network
infrastructure in Azure and how to establish hybrid connectivity, routing, private access to Azure services, and
monitoring in Azure.

Audience

This course is aimed at Network Engineers looking to specialize in Azure networking solutions. An Azure
Network engineer designs and implements core Azure networking infrastructure, hybrid networking
connections, load balance traffic, network routing, private access to Azure services, network security and
monitoring. The azure network engineer will manage networking solutions for optimal performance, resiliency,
scale, and security.

Learning Objectives
By actively participating in this course, you will learn about the following:

» Understanding of on-premises virtualization technologies, including: VMs, virtual networking, and virtual
hard disks.

» Understanding of network configurations, including TCP/IP, Domain Name System (DNS), virtual
private networks (VPNSs), firewalls, and encryption technologies.

» Understanding of software defined networking.

» Understanding hybrid network connectivity methods, such as VPN.

» Understanding resilience and disaster recovery, including high availability and restore operations

Pre-Requisites
Successful Azure Network Engineers start this role with experience in enterprise networking, on-premises or
cloud infrastructure and network security.
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Course Contents

Module 1: Azure Virtual Networks
In this module you will learn how to design and implement fundamental Azure Networking resources such as
virtual networks, public and private IPs, DNS, virtual network peering, routing, and Azure Virtual NAT.

Azure Virtual Networks
Public IP Services

Public and Private DNS
Cross-VNet connectivity
Virtual Network Routing
Azure virtual Network NAT

FFIFIFFY

Lab 1: Design and implement a Virtual Network in Azure
Lab 2: Configure DNS settings in Azure
Lab 3: Connect Virtual Networks with Peering

After completing module 1, students will be able to:
Implement virtual networks

Configure public IP services

Configure private and public DNS zones

Design and implement cross-VNET connectivity
Implement virtual network routing

Design and implement an Azure Virtual Network NAT

FIFIFIFIFY

Module 2: Design and Implement Hybrid Networking
In this module you will learn how to design and implement hybrid networking solutions such as Site-to-Site
VPN connections, Point-to-Site VPN connections, Azure Virtual WAN and Virtual WAN hubs.

» Site-to-site VPN connection
» Point-to-Site VP connections
» Azure Virtual WAN

Lab 4: Create and configure a local gateway
» Create and configure a virtual network gateway
» Create a Virtual WAN by using Azure Portal
» Design and implement a site-to-site VPN connection
» Design and implement a point-to-site VPN connection
» Design and implement authentication
» Design and implement Azure Virtual WAN Resources

Module 3: Design and Implement Azure ExpressRoute
In this module you will learn how to design and implement Azure ExpressRoute, ExpressRoute Global Reach,
ExpressRoute FastPath and ExpressRoute Peering options.

» ExpressRoute

»  ExpressRoute Direct

» ExpressRoute FastPath
» ExpressRoute Peering

Lab 5: Create and configure ExpressRoute
» Design and implement Expressroute
» Design and implement Expressroute Direct
» Design and implement Expressroute FastPath
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Module 4: Load Balancing non-HTTP(S) Traffic in Azure
In this module you will learn how to design and implement load balancing solutions for non-HTTP(S) traffic in
Azure with Azure Load balancer and Traffic Manager.

Content Delivery and Load Balancing
Azure Load balancer

Azure Traffic Manager

Azure Monitor

Network Watcher

FFIFFF

Lab 6: Create and configure a public load balancer to load balance VMs using the Azure portal
Lab:7 Create a Traffic Manager Profile using the Azure portal
Lab 8: Create, view, and manage metric alerts in Azure Monitor

Design and implement Azure Load Balancers
Design and implement Azure Traffic Manager
Monitor Networks with Azure Monitor

Use Network Watcher

FFFF

Module 5: Load Balancing HTTP(S) Traffic in Azure
In this module you will learn how to design and implement load balancing solutions for HTTP(S) traffic in
Azure with Azure Application gateway and Azure Front Door.

»  Azure Application Gateway
»  Azure Front Door

Lab 9: Create a Front Door for a highly available web application using the Azure portal
Lab 10: Create and Configure an Application Gateway

»  Design and implement Azure Application Gateway
» Implement Azure Front Door

Module 6: Design and Implement Network Security
In this module you will learn to design and imponent network security solutions such as Azure DDoS, Azure
Firewalls, Network Security Groups, and Web Application Firewall.

Azure DDoS Protection

Azure Firewall

Network Security Groups

Web Application Firewall on Azure Front Door

FIFEFFY

Lab 11: Create a Virtual Network with DDoS protection plan
Lab 12: Deploy and Configure Azure Firewall
Lab 13: Create a Web Application Firewall policy on Azure Front Door

»  Configure and monitor an Azure DDoS protection plan

» implement and manage Azure Firewall

» Implement network security groups

» Implement a web application firewall (WAF) on Azure Front Door
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Module 7: Design and Implement Private Access to Azure Services

In this module you will learn to design and implement private access to Azure Services with Azure Private

Link, and virtual network service endpoints.

Define Azure Private Link and private endpoints

Design and Configure Private Endpoints

Integrate a Private Link with DNS and on-premises clients
Create, configure, and provide access to Service Endpoints
Configure VNET integration for App Service

FFIFFF

Lab 14: restrict network access to PaaS resources with virtual network service endpoints

Lab 15: create an Azure private endpoint

Define the difference between Private Link Service and private endpoints
Design and configure private endpoints

Explain virtual network service endpoints

Design and configure access to service endpoints

Integrate Private Link with DNS

Integrate your App Service with Azure virtual networks

FIFIFIFFT

Exam Details
This course helps you prepare for the Microsoft Exam AZ-700
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skilltec Microsoft Azure
tra]'n]'ng Fundamentals (2-day)

Moving forward in knowledge and training

Course Code MAZ900
Duration 2 days

Overview
This 2-day course is identical to the 1-day MAZ900-01 course. However, this course lasts two days because
of the hands-on parts. This course will prepare students for the same exam AZ-900.

This course will provide foundational level knowledge of cloud services and how those services are provided
with Microsoft Azure. The course can be taken as an optional first step in learning about cloud services and
Microsoft Azure, before taking further Microsoft Azure or Microsoft cloud services courses.

The course will cover general cloud computing concepts as well as general cloud computing models and
services such as Public, Private and Hybrid cloud and Infrastructure-as-a-Service (laaS), Platform-as-a-
Service(PaaS) and Software-as-a-Service (SaaS).

It will also cover some core Azure services and solutions, as well as key Azure pillar services concerning
security, privacy, compliance and trust. It will finally cover pricing and support services available with Azure.

Audience

This course is suitable for program managers and technical sales, with a general IT background. These
delegates want to learn about our offerings, see how components are implemented, and ask questions about
products and features. This course will help prepare someone for the AZ-900 exam.

Learning Objectives
By actively participating in this course, you will learn about the following:

Understand general cloud computing concepts

Understand core services available with Microsoft Azure

Understand security, privacy, compliance and trust with Microsoft Azure
Understand pricing and support models available with Microsoft

FFF Y

Pre-Requisites
There are no pre-requisites for taking this course. Technical IT experience is not required however some
general IT knowledge or experience would be beneficial.
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Course Contents

Module 1: Cloud Concepts

In this module you will learn basic cloud concepts.
Learning Objectives

Why Cloud Services?

FIFEFFF

Public, Private, and Hybrid cloud models

After completing module 1, students will be able:
» Understand general cloud computing concepts

Module 2: Core Azure Services

In this module you will learn the basics core services available with Microsoft Azure.
Core Azure architectural components

Core Azure Services and Products

Azure Solutions

Azure management tools

FFEFFY

After completing module 2, students will be able:
» Understand core services available with Microsoft Azure

Module 3: Security, Privacy, Compliance and Trust

In this module, you learn about security, privacy, compliance, and trust with Microsoft Azure.

Securing network connectivity in Azure

Core Azure ldentity services

Security tools and features

Azure governance methodologies

Monitoring and Reporting in Azure

Privacy, Compliance and Data Protection standards in Azure

FFIFIFFT

After completing module 3, students will be able:
» Understand security, privacy, compliance and trust with Microsoft Azure

Module 4: Azure Pricing and Support
In this module, you will focus on pricing and support models available with Microsoft.
»  Azure subscriptions
» Planning and managing costs
»  Support options available with Azure
»  Service lifecycle in Azure

After completing module 4, students will be able:
» Understand pricing and support models available with Microsoft

Infrastructure-as-a-Service (laaS), Platform-as-a-Service (PaaS) and Software-as-a-Service (SaaS)

Exam Details

This course leads to the AZ-900 Microsoft Azure Fundamentals exam, which will earn you the

Microsoft Certified: Azure Fundamentals certification.
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skilltec Microsoft Azure
traim'ng Fundamentals (1-day)

Moving forward in knowledge and training

Course Code MAZ900-01
Duration 1 day

Overview

This one-day course will provide foundational level knowledge on Azure concepts; core Azure services; core
solutions and management tools; general security and network security; governance, privacy, and compliance
features; Azure cost management and service level agreements.

Note: This course does not provide an Azure pass or time for delegates to participate in hands-on labs. If you
are interested in a more interactive hands-on lab experience, consider our MAZ900: Microsoft Azure
Fundamentals (2-day) course, which includes trainer-directed hands-on labs. The content for both courses
align to the AZ-900 exam objective domain.

Audience
The audience for this course should be people involved in selling or buying cloud products, or people that
have never seen cloud before. This isn't a technical course and has no, official, hands-on exercises.

Learning Objectives
By actively participating in this course, you will learn about the following:

Understand general cloud computing concepts

Understand core services available with Microsoft Azure

Understand security, privacy, compliance and trust with Microsoft Azure
Understand pricing and support models available with Microsoft

FFEF Y

Pre-Requisites
There are no pre-requisites for taking this course. Technical IT experience is not required however some
general IT knowledge or experience would be beneficial.
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Course Contents

Module 1: Cloud Concepts
In this module you will learn basic cloud concepts.

Lessons for module 1

Learning Objectives

Why Cloud Services?

Infrastructure-as-a-Service (laaS), Platform-as-a-Service (PaaS) and Software-as-a-Service (SaaS)
Public, Private, and Hybrid cloud models

FFFF

After completing module 1, students will be able:
» Understand general cloud computing concepts

Module 2: Core Azure Services
In this module you will learn the basics core services available with Microsoft Azure.

Lessons for module 2

Core Azure architectural components
Core Azure Services and Products
Azure Solutions

Azure management tools

FIFF ¥

After completing module 2, students will be able:
» Understand core services available with Microsoft Azure

Module 3: Security, Privacy, Compliance and Trust
In this module, you learn about security, privacy, compliance, and trust with Microsoft Azure.

Lessons for module 3

Securing network connectivity in Azure

Core Azure ldentity services

Security tools and features

Azure governance methodologies

Monitoring and Reporting in Azure

Privacy, Compliance and Data Protection standards in Azure

FFIFIFFYF

After completing module 3, students will be able:
» Understand security, privacy, compliance and trust with Microsoft Azure

Module 4: Azure Pricing and Support
In this module, you will focus on pricing and support models available with Microsoft.

Lessons for module 4
»  Azure subscriptions
» Planning and managing costs
»  Support options available with Azure
»  Service lifecycle in Azure

After completing module 4, students will be able:
» Understand pricing and support models available with Microsoft

Exam Details
This course leads to the AZ-900 Microsoft Azure Fundamentals exam, which will earn you the
Microsoft Certified: Azure Fundamentals certification.
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skilltec Designing and
training Implementing a Data

Moving forward in knowledge and training S Ci e n Ce S O I u ti O n O n
Azure
Course Code  MDP100
Duration 3 days
Overview

Learn how to operate machine learning solutions at cloud scale using Azure Machine Learning. This course
teaches you to leverage your existing knowledge of Python and machine learning to manage data ingestion
and preparation, model training and deployment, and machine learning solution monitoring in Microsoft Azure.

Audience

This course is designed for data scientists with existing knowledge of Python and machine learning
frameworks like Scikit-Learn, PyTorch, and Tensorflow, who want to build and operate machine learning
solutions in the cloud.

Learning Objectives
By actively participating in this course, you will learn about the following:

Setting up an Azure Machine Learning workspace.
Running experiments and train models.
Optimizing and manage models.

Deploying and consuming models.

F¥EFF ¥

Pre-Requisites
Successful Azure Data Scientists start this role with a fundamental knowledge of cloud computing concepts,
and experience in general data science and machine learning tools and techniques.

Specifically:
» Creating cloud resources in Microsoft Azure.
» Using Python to explore and visualize data.
»  Training and validating machine learning models using common frameworks like Scikit-Learn,
PyTorch, and TensorFlow.
»  Working with containers
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Course Contents

Module 1: Getting Started with Azure Machine Learning

In this module, you will learn how to provision an Azure Machine Learning workspace and use it to manage
machine learning assets such as data, compute, model training code, logged metrics, and trained models.
You will learn how to use the web-based Azure Machine Learning studio interface as well as the Azure
Machine Learning SDK and developer tools like Visual Studio Code and Jupyter Notebooks to work with the
assets in your workspace.

Lessons
» Introduction to Azure Machine Learning
»  Working with Azure Machine Learning

Lab: Create an Azure Machine Learning Workspace

After completing this module, you will be able to:
»  Provision an Azure Machine Learning workspace.
» Use tools and code to work with Azure Machine Learning.

Module 2: No-Code Machine Learning
This module introduces the Automated Machine Learning and Designer visual tools, which you can use to
train, evaluate, and deploy machine learning models without writing any code.

Lessons
» Automated Machine Learning
»  Azure Machine Learning Designer

Labs
» Use Automated Machine Learning
» Use Azure Machine Learning Designer

After completing this module, you will be able to:
» Use automated machine learning to train a machine learning model.
» Use Azure Machine Learning designer to train a model.

Module 3: Running Experiments and Training Models
In this module, you will get started with experiments that encapsulate data processing and model training
code and use them to train machine learning models.

Lessons
» Introduction to Experiments
»  Training and Registering Models

Labs
» Run Experiments
» Train Models

After completing this module, you will be able to:

» Run code-based experiments in an Azure Machine Learning workspace.
»  Train and register machine learning models.
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Module 4: Working with Data

Data is a fundamental element in any machine learning workload, so in this module, you will learn how to
create and manage datastores and datasets in an Azure Machine Learning workspace, and how to use them
in model training experiments.

Lessons
» Working with Datastores
»  Working with Datasets

Lab: Work with Data

After completing this module, you will be able to:
» Create and use datastores.
» Create and use datasets.

Module 5: Working with Compute

One of the key benefits of the cloud is the ability to leverage compute resources on demand and use them to
scale machine learning processes to an extent that would be infeasible on your own hardware. In this module,
you'll learn how to manage experiment environments that ensure consistent runtime consistency for
experiments, and how to create and use compute targets for experiment runs.

Lessons
»  Working with Environments
»  Working with Compute Targets

Lab: Work with Compute

After completing this module, you will be able to:
» Create and use environments.
» Create and use compute targets.

Module 6: Orchestrating Operations with Pipelines

Now that you understand the basics of running workloads as experiments that leverage data assets and
compute resources, it's time to learn how to orchestrate these workloads as pipelines of connected steps.
Pipelines are key to implementing an effective Machine Learning Operationalization (ML Ops) solution in
Azure, so you'll explore how to define and run them in this module.

Lessons
» Introduction to Pipelines
»  Publishing and Running Pipelines
Lab: Create a Pipeline
After completing this module, you will be able to:

» Create pipelines to automate machine learning workflows.
»  Publish and run pipeline services.
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Module 7: Deploying and Consuming Models

Models are designed to help decision making through predictions, so they're only useful when deployed and
available for an application to consume. In this module learn how to deploy models for real-time inferencing,
and for batch inferencing.

Lessons
» Real-time Inferencing
» Batch Inferencing
» Continuous Integration and Delivery

Labs
» Create a Real-time Inferencing Service
» Create a Batch Inferencing Service

After completing this module, you will be able to:
» Publish a model as a real-time inference service.
» Publish a model as a batch inference service.
» Describe techniques to implement continuous integration and delivery.

Module 8: Training Optimal Models

By this stage of the course, you've learned the end-to-end process for training, deploying, and consuming
machine learning models; but how do you ensure your model produces the best predictive outputs for your
data? In this module, you'll explore how you can use hyperparameter tuning and automated machine learning
to take advantage of cloud-scale compute and find the best model for your data.

Lessons
» Hyperparameter Tuning
»  Automated Machine Learning

Labs
» Tune Hyperparameters
» Use Automated Machine Learning from the SDK

After completing this module, you will be able to:

»  Optimize hyperparameters for model training.
»  Use automated machine learning to find the optimal model for your data.
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Module 9: Responsible Machine Learning

Data scientists have a duty to ensure they analyze data and train machine learning models responsibly,
respecting individual privacy, mitigating bias, and ensuring transparency. This module explores some
considerations and techniques for applying responsible machine learning principles.

Lessons
» Differential Privacy
» Model Interpretability
» Fairness

Labs
» Explore Differential privacy
» Interpret Models
» Detect and Mitigate Unfairness

After completing this module, you will be able to:
»  Apply differential privacy to data analysis
»  Use explainers to interpret machine learning models
» Evaluate models for fairness

Module 10: Monitoring Models

After a model has been deployed, it's important to understand how the model is being used in production, and
to detect any degradation in its effectiveness due to data drift. This module describes techniques for
monitoring models and their data.

Lessons
»  Monitoring Models with Application Insights
»  Monitoring Data Drift

Labs
»  Monitor a Model with Application Insights
»  Monitor Data Drift

After completing this module, you will be able to:
»  Use Application Insights to monitor a published model.
»  Monitor data drift.

Exam Details
This course leads to the DP-100 Designing and Implementing a Data Science Solution on Azure exam, which
will earn you the Microsoft Certified: Azure Data Science Associate certification.
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Moving forward in knowledge and training

Course Code MDP203
Duration 4 days

Overview

In this course, the student will learn about the data engineering patterns and practices as it pertains to
working with batch and real-time analytical solutions using Azure data platform technologies. Students will
begin by understanding the core compute and storage technologies that are used to build an analytical
solution. They will then explore how to design an analytical serving layers and focus on data engineering
considerations for working with source files. The students will learn how to interactively explore data stored in
files in a data lake.

They will learn the various ingestion techniques that can be used to load data using the Apache Spark
capability found in Azure Synapse Analytics or Azure Databricks, or how to ingest using Azure Data Factory
or Azure Synapse pipelines. The students will also learn the various ways they can transform the data using
the same technologies that is used to ingest data. The student will spend time on the course learning how to
monitor and analyze the performance of analytical system so that they can optimize the performance of data
loads, or queries that are issued against the systems. They will understand the importance of implementing
security to ensure that the data is protected at rest or in transit. The student will then show how the data in an
analytical system can be used to create dashboards or build predictive models in Azure Synapse Analytics.

Audience

The primary audience for this course is data professionals, data architects, and business intelligence
professionals who want to learn about data engineering and building analytical solutions using data platform
technologies that exist on Microsoft Azure. The secondary audience for this course data analysts and data
scientists who work with analytical solutions built on Microsoft Azure.

Learning Objectives

By actively participating in this course, you will learn about the following:

Explore compute and storage options for data engineering workloads in Azure
Design and Implement the serving layer

Understand data engineering considerations

Run interactive queries using serverless SQL pools

Explore, transform, and load data into the Data Warehouse using Apache Spark
Perform data Exploration and Transformation in Azure Databricks

Ingest and load Data into the Data Warehouse

Transform Data with Azure Data Factory or Azure Synapse Pipelines

Integrate Data from Notebooks with Azure Data Factory or Azure Synapse Pipelines
Optimize Query Performance with Dedicated SQL Pools in Azure Synapse

Analyze and Optimize Data Warehouse Storage

Support Hybrid Transactional Analytical Processing (HTAP) with Azure Synapse Link
Perform end-to-end security with Azure Synapse Analytics

Perform real-time Stream Processing with Stream Analytics

Create a Stream Processing Solution with Event Hubs and Azure Databricks

Build reports using Power Bl integration with Azure Synpase Analytics

Perform Integrated Machine Learning Processes in Azure Synapse Analytics

FIFIFIFIFFIFIFIFIFIFIFIFFrsry
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Pre-Requisites
Successful students start this course with knowledge of cloud computing and core data concepts and
professional experience with data solutions.

Recommended prerequisites:
» M-DP900 - Microsoft Azure Data Fundamentals
» M-AZ900 - Microsoft Azure Fundamentals (Includes Labs)

Course Contents

Module 1: Explore Compute and Storage Options for Data Engineering Workloads

This module provides an overview of the Azure compute and storage technology options that are available to
data engineers building analytical workloads. This module teaches ways to structure the data lake, and to
optimize the files for exploration, streaming, and batch workloads. The student will learn how to organize the
data lake into levels of data refinement as they transform files through batch and stream processing. Then
they will learn how to create indexes on their datasets, such as CSV, JSON, and Parquet files, and use them
for potential query and workload acceleration.

Lessons M1

Introduction to Azure Synapse Analytics
» Describe Azure Databricks

» Introduction to Azure Data Lake storage
»

»

¥

Describe Delta Lake architecture
Work with data streams by using Azure Stream Analytics

Lab 1: Explore compute and storage options for data engineering workloads
» Combine streaming and batch processing with a single pipeline
» Organize the data lake into levels of file transformation
» Index data lake storage for query and workload acceleration

After completing module 1, students will be able to:
Describe Azure Synapse Analytics

Describe Azure Databricks

Describe Azure Data Lake storage

Describe Delta Lake architecture

Describe Azure Stream Analytics

FFIFFYF
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Module 2: Design and Implement the Serving Layer

This module teaches how to design and implement data stores in a modern data warehouse to optimize
analytical workloads. The student will learn how to design a multidimensional schema to store fact and
dimension data. Then the student will learn how to populate slowly changing dimensions through incremental
data loading from Azure Data Factory.

Lessons M2
» Design a multidimensional schema to optimize analytical workloads
» Code-free transformation at scale with Azure Data Factory
» Populate slowly changing dimensions in Azure Synapse Analytics pipelines

Lab 2: Designing and Implementing the Serving Layer
» Design a star schema for analytical workloads
» Populate slowly changing dimensions with Azure Data Factory and mapping data flows

After completing module 2, students will be able to:
» Design a star schema for analytical workloads
» Populate a slowly changing dimensions with Azure Data Factory and mapping data flows

Module 3: Data Engineering Considerations for Source Files

This module explores data engineering considerations that are common when loading data into a modern
data warehouse analytical from files stored in an Azure Data Lake and understanding the security
consideration associated with storing files stored in the data lake.

Lessons M3
» Design a Modern Data Warehouse using Azure Synapse Analytics
» Secure a data warehouse in Azure Synapse Analytics

Lab 3: Data engineering considerations
» Managing files in an Azure data lake
»  Securing files stored in an Azure data lake

After completing module 3, students will be able to:

» Design a Modern Data Warehouse using Azure Synapse Analytics
» Secure a data warehouse in Azure Synapse Analytics
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Module 4: Run Interactive Queries using Azure Synapse Analytics Serverless SQL Pools

In this module, students will learn how to work with files stored in the data lake and external file sources,
through T-SQL statements executed by a serverless SQL pool in Azure Synapse Analytics. Students will
query Parquet files stored in a data lake, as well as CSV files stored in an external data store. Next, they will
create Azure Active Directory security groups and enforce access to files in the data lake through Role-Based
Access Control (RBAC) and Access Control Lists (ACLS).

Lessons M4
» Explore Azure Synapse serverless SQL pools capabilities
» Query data in the lake using Azure Synapse serverless SQL pools
» Create metadata objects in Azure Synapse serverless SQL pools
»  Secure data and manage users in Azure Synapse serverless SQL pools

Lab 4: Run interactive queries using serverless SQL pools

Query Parquet data with serverless SQL pools

Create external tables for Parquet and CSV files

Create views with serverless SQL pools

Secure access to data in a data lake when using serverless SQL pools

Configure data lake security using Role-Based Access Control (RBAC) and Access Control List

FFIFFF

After completing module 4, students will be able to:
» Understand Azure Synapse serverless SQL pools capabilities
» Query data in the lake using Azure Synapse serverless SQL pools
» Create metadata objects in Azure Synapse serverless SQL pools
» Secure data and manage users in Azure Synapse serverless SQL pools

Module 5: Explore, Transform, and Load Data into the Data Warehouse using Apache Spark

This module teaches how to explore data stored in a data lake, transform the data, and load data into a
relational data store. The student will explore Parquet and JSON files and use techniques to query and
transform JSON files with hierarchical structures. Then the student will use Apache Spark to load data into the
data warehouse and join Parquet data in the data lake with data in the dedicated SQL pool.

Lessons M5
» Understand big data engineering with Apache Spark in Azure Synapse Analytics
» Ingest data with Apache Spark notebooks in Azure Synapse Analytics
» Transform data with DataFrames in Apache Spark Pools in Azure Synapse Analytics
» Integrate SQL and Apache Spark pools in Azure Synapse Analytics

Lab 5: Explore, transform, and load data into the Data Warehouse using Apache Spark
»  Perform Data Exploration in Synapse Studio
» Ingest data with Spark notebooks in Azure Synapse Analytics
»  Transform data with DataFrames in Spark pools in Azure Synapse Analytics
» Integrate SQL and Spark pools in Azure Synapse Analytics

After completing module 5, students will be able to:
» Describe big data engineering with Apache Spark in Azure Synapse Analytics
» Ingest data with Apache Spark notebooks in Azure Synapse Analytics
» Transform data with DataFrames in Apache Spark Pools in Azure Synapse Analytics
» Integrate SQL and Apache Spark pools in Azure Synapse Analytics
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Module 6: Data Exploration and Transformation in Azure Databricks

This module teaches how to use various Apache Spark DataFrame methods to explore and transform data in
Azure Databricks. The student will learn how to perform standard DataFrame methods to explore and
transform data. They will also learn how to perform more advanced tasks, such as removing duplicate data,
manipulate date/time values, rename columns, and aggregate data.

Lessons M6
» Describe Azure Databricks
» Read and write data in Azure Databricks
»  Work with DataFrames in Azure Databricks
»  Work with DataFrames advanced methods in Azure Databricks

Lab 6: Data Exploration and Transformation in Azure Databricks
» Use DataFrames in Azure Databricks to explore and filter data
» Cache a DataFrame for faster subsequent queries
» Remove duplicate data
» Manipulate date/time values
» Remove and rename DataFrame columns
» Aggregate data stored in a DataFrame

After completing module 6, students will be able to:
» Describe Azure Databricks
» Read and write data in Azure Databricks
»  Work with DataFrames in Azure Databricks
»  Work with DataFrames advanced methods in Azure Databricks

Module 7: Ingest and Load Data into the Data Warehouse

This module teaches students how to ingest data into the data warehouse through T-SQL scripts and
Synapse Analytics integration pipelines. The student will learn how to load data into Synapse dedicated SQL
pools with PolyBase and COPY using T-SQL. The student will also learn how to use workload management
along with a Copy activity in a Azure Synapse pipeline for petabyte-scale data ingestion.

Lessons M7
» Use data loading best practices in Azure Synapse Analytics
» Petabyte-scale ingestion with Azure Data Factory

Lab 7: Ingest and load Data into the Data Warehouse
» Perform petabyte-scale ingestion with Azure Synapse Pipelines
» Import data with PolyBase and COPY using T-SQL
» Use data loading best practices in Azure Synapse Analytics

After completing module 7, students will be able to:

» Use data loading best practices in Azure Synapse Analytics
» Petabyte-scale ingestion with Azure Data Factory
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Module 8: Transform Data with Azure Data Factory or Azure Synapse Pipelines
This module teaches students how to build data integration pipelines to ingest from multiple data sources,
transform data using mapping data flows, and perform data movement into one or more data sinks.

Lessons M8
» Data integration with Azure Data Factory or Azure Synapse Pipelines
» Code-free transformation at scale with Azure Data Factory or Azure Synapse Pipelines

Lab 8: Transform Data with Azure Data Factory or Azure Synapse Pipelines
» Execute code-free transformations at scale with Azure Synapse Pipelines
» Create data pipeline to import poorly formatted CSV files
» Create Mapping Data Flows

After completing module 8, students will be able to:
» Perform data integration with Azure Data Factory
» Perform code-free transformation at scale with Azure Data Factory

Module 9: Orchestrate Data Movement and Transformation in Azure Synapse Pipelines
In this module, you will learn how to create linked services, and orchestrate data movement and
transformation using notebooks in Azure Synapse Pipelines.

Lessons M9
»  Orchestrate data movement and transformation in Azure Data Factory

Lab 9: Orchestrate data movement and transformation in Azure Synapse Pipelines
» Integrate Data from Notebooks with Azure Data Factory or Azure Synapse Pipelines

After completing module 9, students will be able to:
» Orchestrate data movement and transformation in Azure Synapse Pipelines

Module 10: Optimize Query Performance with Dedicated SQL Pools in Azure Synapse

In this module, students will learn strategies to optimize data storage and processing when using dedicated
SQL pools in Azure Synapse Analytics. The student will know how to use developer features, such as
windowing and HyperLog functions, use data loading best practices, and optimize and improve query
performance.

Lessons M10
» Optimize data warehouse query performance in Azure Synapse Analytics
» Understand data warehouse developer features of Azure Synapse Analytics

Lab 10: Optimize Query Performance with Dedicated SQL Pools in Azure Synapse
» Understand developer features of Azure Synapse Analytics
» Optimize data warehouse query performance in Azure Synapse Analytics
» Improve query performance

After completing module 10, students will be able to:

» Optimize data warehouse query performance in Azure Synapse Analytics
» Understand data warehouse developer features of Azure Synapse Analytics
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Module 11: Analyze and Optimize Data Warehouse Storage

In this module, students will learn how to analyze then optimize the data storage of the Azure Synapse
dedicated SQL pools. The student will know techniques to understand table space usage and column store
storage details. Next the student will know how to compare storage requirements between identical tables
that use different data types. Finally, the student will observe the impact materialized views have when
executed in place of complex queries and learn how to avoid extensive logging by optimizing delete
operations.

Lessons M11
» Analyze and optimize data warehouse storage in Azure Synapse Analytics

Lab 11: Analyze and Optimize Data Warehouse Storage
» Check for skewed data and space usage
» Understand column store storage details
»  Study the impact of materialized views
»  Explore rules for minimally logged operations

After completing module 11, students will be able to:
» Analyze and optimize data warehouse storage in Azure Synapse Analytics

Module 12: Support Hybrid Transactional Analytical Processing (HTAP) with Azure Synapse Link
In this module, students will learn how Azure Synapse Link enables seamless connectivity of an Azure
Cosmos DB account to a Synapse workspace. The student will understand how to enable and configure
Synapse link, then how to query the Azure Cosmos DB analytical store using Apache Spark and SQL
serverless.

Lessons M12

Design hybrid transactional and analytical processing using Azure Synapse Analytics
» Configure Azure Synapse Link with Azure Cosmos DB
»  Query Azure Cosmos DB with Apache Spark pools
»  Query Azure Cosmos DB with serverless SQL pools

Lab 12: Support Hybrid Transactional Analytical Processing (HTAP) with Azure Synapse Link
» Configure Azure Synapse Link with Azure Cosmos DB
»  Query Azure Cosmos DB with Apache Spark for Synapse Analytics
»  Query Azure Cosmos DB with serverless SQL pool for Azure Synapse Analytics

After completing module 12, students will be able to:
» Design hybrid transactional and analytical processing using Azure Synapse Analytics
»  Configure Azure Synapse Link with Azure Cosmos DB
»  Query Azure Cosmos DB with Apache Spark for Azure Synapse Analytics
»  Query Azure Cosmos DB with SQL serverless for Azure Synapse Analytics
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Module 13: End-to-end Security with Azure Synapse Analytics

In this module, students will learn how to secure a Synapse Analytics workspace and its supporting
infrastructure. The student will observe the SQL Active Directory Admin, manage IP firewall rules, manage
secrets with Azure Key Vault and access those secrets through a Key Vault linked service and pipeline
activities. The student will understand how to implement column-level security, row-level security, and
dynamic data masking when using dedicated SQL pools.

Lessons M13
» Secure a data warehouse in Azure Synapse Analytics
» Configure and manage secrets in Azure Key Vault
» Implement compliance controls for sensitive data

Lab 13: End-to-end security with Azure Synapse Analytics
»  Secure Azure Synapse Analytics supporting infrastructure
» Secure the Azure Synapse Analytics workspace and managed services
» Secure Azure Synapse Analytics workspace data

After completing module 13, students will be able to:
» Secure a data warehouse in Azure Synapse Analytics
» Configure and manage secrets in Azure Key Vault
» Implement compliance controls for sensitive data

Module 14: Real-time Stream Processing with Stream Analytics

In this module, students will learn how to process streaming data with Azure Stream Analytics. The student
will ingest vehicle telemetry data into Event Hubs, then process that data in real time, using various
windowing functions in Azure Stream Analytics. They will output the data to Azure Synapse Analytics. Finally,
the student will learn how to scale the Stream Analytics job to increase throughput.

Lessons M14
» Enable reliable messaging for Big Data applications using Azure Event Hubs
»  Work with data streams by using Azure Stream Analytics
» Ingest data streams with Azure Stream Analytics

Lab 14: Real-time Stream Processing with Stream Analytics
» Use Stream Analytics to process real-time data from Event Hubs
» Use Stream Analytics windowing functions to build aggregates and output to Synapse Analytics
» Scale the Azure Stream Analytics job to increase throughput through partitioning
» Repartition the stream input to optimize parallelization

After completing module 14, students will be able to:
» Enable reliable messaging for Big Data applications using Azure Event Hubs
»  Work with data streams by using Azure Stream Analytics
» Ingest data streams with Azure Stream Analytics

Page 65 of 75



Module 15: Create a Stream Processing Solution with Event Hubs and Azure Databricks

In this module, students will learn how to ingest and process streaming data at scale with Event Hubs and
Spark Structured Streaming in Azure Databricks. The student will learn the key features and uses of
Structured Streaming. The student will implement sliding windows to aggregate over chunks of data and apply
watermarking to remove stale data. Finally, the student will connect to Event Hubs to read and write streams.

Lessons M15
»  Process streaming data with Azure Databricks structured streaming

Lab 15: Create a Stream Processing Solution with Event Hubs and Azure Databricks
Explore key features and uses of Structured Streaming

Stream data from a file and write it out to a distributed file system

Use sliding windows to aggregate over chunks of data rather than all data
Apply watermarking to remove stale data

Connect to Event Hubs read and write streams

FFIFF¥

After completing module 15, students will be able to:
»  Process streaming data with Azure Databricks structured streaming

Module 16: Build Reports using Power Bl Integration with Azure Synpase Analytics

In this module, the student will learn how to integrate Power Bl with their Synapse workspace to build reports
in Power BIl. The student will create a new data source and Power Bl report in Synapse Studio. Then the
student will learn how to improve query performance with materialized views and result-set caching. Finally,
the student will explore the data lake with serverless SQL pools and create visualizations against that data in
Power BI.

Lessons M16
»  Create reports with Power Bl using its integration with Azure Synapse Analytics

Lab 16: Build reports using Power Bl integration with Azure Synpase Analytics
» Integrate an Azure Synapse workspace and Power Bl
»  Optimize integration with Power Bl
» Improve query performance with materialized views and result-set caching
» Visualize data with SQL serverless and create a Power Bl report

After completing module 16, students will be able to:
» Create reports with Power Bl using its integration with Azure Synapse Analytics
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Module 17: Perform Integrated Machine Learning Processes in Azure Synapse Analytics

This module explores the integrated, end-to-end Azure Machine Learning and Azure Cognitive Services
experience in Azure Synapse Analytics. You will learn how to connect an Azure Synapse Analytics workspace
to an Azure Machine Learning workspace using a Linked Service and then trigger an Automated ML
experiment that uses data from a Spark table. You will also learn how to use trained models from Azure
Machine Learning or Azure Cognitive Services to enrich data in a SQL pool table and then serve prediction
results using Power BI.

Lessons M17
» Use the integrated machine learning process in Azure Synapse Analytics

Lab 17: Perform Integrated Machine Learning Processes in Azure Synapse Analytics
» Create an Azure Machine Learning linked service
»  Trigger an Auto ML experiment using data from a Spark table
» Enrich data using trained models
»  Serve prediction results using Power Bl

After completing module 17, students will be able to:
» Use the integrated machine learning process in Azure Synapse Analytics

Exam Details
There is no exam relating directly to this course.
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skilltec Administering Relational
train]'ng Databases on Microsoft

Moving forward in knowledge and training AZ u re
Course Code MDP300
Duration 4 days
Overview

This course provides delegates with the knowledge and skills to administer a SQL Server database
infrastructure for cloud, on-premises and hybrid relational databases and who work with the Microsoft PaaS
relational database offerings. Additionally, it will be of use to individuals who develop applications that deliver
content from SQL-based relational databases.

Audience

The audience for this course is data professionals managing data and databases who want to learn about
administering the data platform technologies that are available on Microsoft Azure. This course is also
valuable for data architects and application developers who need to understand what technologies are
available for the data platform with Azure and how to work with those technologies through applications.

Learning Objectives
By actively participating in this course, you will learn about the following:

» Planning, deploying and configuring Azure SQL offerings.
» Monitoring database performance and tuning a database and queries for optimum performance.
» Planning and configuring a High Availability Solution.

Pre-Requisites

Successful Azure Database Administrators start this role with professional experience in database
management and technical knowledge of cloud technologies.

Specifically:

»  Working with, maintaining, and developing with SQL Server.
» Experience with Azure, such as deploying and managing resources.
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Course Contents

Module 1: The Role of the Azure Database Administrator

This module explores the role of a database administrator in the world of Azure. It also provides some
foundational information relevant to the overall content. This includes a review of the various SQL Server-
based options (SQL Server in a VM, Managed Instances, and Azure SQL Database.) Delegates will learn
why compatibility level is a crucial concept when working with SQL databases in Azure. Delegates are also
introduced to other database platforms available on Azure in addition to those based on SQL Server, in
particular PostgreSQL and MySQL.

Lessons
» Azure Data Platform Roles
» Azure Database Platforms and Options
» SQL Server Compatibility Levels
»  Azure Preview Features

Lab: Using the Azure Portal and SQL Server Management Studio
»  Provision a SQL Server on an Azure Virtual Machine
» Connect to SQL Server and Restore a Backup

After completing this module, delegates will:
» Understand the role of Azure Database Administrator as it fits in with other data platform roles.
» Be able to describe the key differences between the SQL Server-based database op.
» Be able to describe the difference between versions and compatibility levels.
»  Know how to enable and disable preview features.

Module 2: Plan and Implement Data Platform Resources

This module introduces methods for deploying data platform resources in Azure. You will learn about options
for both upgrading and migrating existing SQL databases to Azure. You will learn how to set up Azure
resources to host SQL Server on a Virtual Machine, a Managed Instance, Azure SQL Database and either
PostgreSQL or MySQL. You will learn how to determine which options are best based on specific
requirements including the High Availability and Disaster Recovery (HADR) needs. They will learn to calculate
resource requirements and create templates for their deployments.

Lessons
» Deploying SQL Server using laaS
» Deploying SQL Server using PaaS
» Deploying Open Source Database Solutions on Azure

Lab: Deploying Azure SQL Database

Deploy a VM using an ARM template

Configure resources needed prior to creating a database

Deploy an Azure SQL Database

Register the Azure SQL Database instance in Azure Data Studio and validate connectivity
Deploy PostgreSQL or MySQL using a client tool to validate connectivity

FFIFFF

After completing this module, delegates will be able to:
» Deploy resources using manual methods.
» Recommend an appropriate database offering based on requirements.
» Configure database resources.
» Evaluate and implement a strategy for moving a database to Azure.
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Module 3: Implement a Secure Environment

This module explores the practices of securing your SQL Server Database as well as an Azure SQL
database. This includes a review of the various SQL Server-based options as well as the various Azure
options for securing Azure SQL Database as well as the databases with reside within Azure SQL Database. .
Delegates will lean why security is crucial when working with databases. . Delegates are also introduced to
other database platforms available on Azure in addition to those based on SQL Server, in particular, Azure
Database for MariaDB/MySQL/PostgreSQL.

Lessons

Configure Database Authentication

Configure Database Authorization

Implement Security for Data at Rest

Implement Security for Data in Transit

Implement Compliance Controls for Sensitive Data

FFIFF¥

Lab: Implement a Secure Environment
» Configure a server-based firewall rule using the Azure Portal
»  Authorize Access to Azure SQL Database with Azure Active Directory
» Enable Advanced Data Security and Data Classification
» Manage access to database objects

After completing this module, delegates will be able to:
» Understand the differences between Windows, SQL Server and Azure Active Directory Authentication.
» Describe and configure both data-at-rest encryption solutions as well as data-in-transit encryption.
» Implement a data sensitivity solution.

Module 4: Monitor and Optimize Operational Resources

This module will teach you about resource optimization for your databases created using either laaS or PaaS
services. The module also covers monitoring server and hardware resources. It will familiarize you with the
various tools available for monitoring performance and establishing a baseline. You will learn how to interpret
performance metrics for the most critical resources. You will also learn how to troubleshoot database
performance using Azure SQL Database Intelligent Insights.

Lessons

Baselines and Performance Monitoring

Major Causes of Performance Issues
Configuring Resources for Optimal Performance
User Database Configuration
Performance-related Maintenance Tasks

FIFIFFY

Lab: Monitor and Optimize Resources
» Isolate CPU Problems
» Use Query Store observe blocking problems
» Detect and correct fragmentation issues

After completing this module, delegates will be able to:
Monitor activity and compare to a baseline.

Define maintenance tasks related to performance.
Identify major causes of performance problems.
Configure resources for optimal performance.
Configure a user database for optimal performance.

FFIFFF

Page 70 of 75



Module 5: Optimize Query Performance

Query execution plans are potentially the most important aspect of database performance. Improving bad
plans is certainly an area where a small amount of effort can bring huge improvements. While hardware
issues can limit query performance, improving hardware usually yields performance improvements in the 10-
20% range, at most. More commonly database administrators encounter queries that are not optimized, have
stale or missing statistics, have missing indexes, or poor database design choices that lead to the database
engine doing more work than is necessary to return results for a given query. Improving the plans can
sometimes yield performance improvements in the 100-200% range or even more, meaning that after
improving a plan with better indexes or statistics, a query could run twice or three times as fast! This module
provides details on how to analyze individual query performance and determine where improvements can be
made.

Lessons
» Understanding SQL Server Query Plans
» Explore Performance-based Database Design
» Evaluate Performance Improvements

Lab: Query Performance Troubleshooting
» Identify issues with database design AdventureWorks2017
» Isolate problem areas in poorly performing queries in AdventureWorks2017
» Use Query Store to detect and handle regression in AdventureWorks2017
» Use query hints to impact performance in AdventureWorks2017

After completing this module, delegates will be able to:
» Analyze query plans and identify problem areas.
» Evaluate potential query improvements.
» Review table and index design.
» Determine whether query or design changes have had a positive effect.

Module 6: Automation of Tasks

A common goal for database administrators in many environments is to automate as many of their repetitive
tasks. This can be as simple as using scripting to automate a backup process, and as complex as building a
fully automated alerting system. This module provides details of automating tasks to simplify the DBA'’s job.
Methods include scheduling tasks for regular maintenance jobs, as well as multi-instance administration and
configuration of notifications for task success or failure or non-completion.

Lessons
»  Setting up Automatic Deployment
» Defining Scheduled Tasks
»  Configuring Extended Events
» Managing Azure PaaS resources Using Automated Methods

Lab: Automating Tasks
» Deploy an Azure template from a Quickstart template on GitHub
»  Configure notifications based on performance metrics
» Deploy an Azure Automation Runbook (or elastic job) to rebuild indexes on an Azure SQL Database

After completing this module, delegates will be able to:
» Deploy resources using automated deployment scripts.
» Create scheduled tasks.
»  Create notifications and alerts.
»  Configure automation for PaaS services.
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Module 7: Plan and Implement a High Availability and Disaster Recovery Environment

Data must be available when the business needs it. That means the solutions hosting the data must be
designed with availability and recoverability in mind. Suppose you work for a company that sells widgets both
in stores and online. Your main application uses a highly transactional database for orders. What would
happen if the server or platform hosting the transactional database had a problem that made it unavailable or
inaccessible for some reason? What impact would it have on the business? If the right solution is put in place,
the database would come online in a reasonable timeframe with minimal effort, thus allowing business to
continue with little-to-no impact. This module and its associated lab cover configuring, testing, and managing
a solution for high availability and disaster recovery (HADR) in Azure, for both Infrastructure-as-a-Service
(laaS) and Platform-as-a-Service (PaaS) deployments. This module will not only cover basic requirements,
but also the various options available to achieve HADR.

Lessons
» High Availability and Disaster Recovery Strategies
» laaS Platform and Database Tools for HADR
» PaaS Platform and Database Tools for HADR
» Database Backup and Recovery

Lab: Plan and Implement a High Availability and Disaster Recovery Environment
» Create an Always On Availability Group
» Enable Geo-Replication for Azure SQL Database
» Backup to URL and Restore from URL

After completing this module, delegates will understand:

The difference between recovery time and recovery point objectives.

The available HADR options for both laaS and PaaS.

The considerations for planning and configuring HADR solutions including how backup and restore.
The factors that comprise a HADR strategy.

How to configure a high availability solution via a hands-on lab.

FFIFF¥

Exam Details
This course leads to the DP-300 Administering Relational Databases on Microsoft Azure exam, which will
earn you the Microsoft Certified: Azure Database Administrator Associate certification.
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skilltec Microsoft Azure Data
training Fundamentals

Moving forward in knowledge and training

Course Code MDP900
Duration 1 day

Overview

In this course, delegates will learn the fundamentals of database concepts in a cloud environment, get basic
skilling in cloud data services, and build their foundational knowledge of cloud data services within Microsoft
Azure. Delegates will identify and describe core data concepts such as relational, non-relational, big data, and
analytics, and explore how this technology is implemented with Microsoft Azure. They will explore the roles,
tasks, and responsibilities in the world of data. The delegates will explore relational data offerings,
provisioning and deploying relational databases, and querying relational data through cloud data solutions
with Microsoft Azure. They will explore non-relational data offerings, provisioning and deploying non-relational
databases, and non-relational data stores with Microsoft Azure. Delegates will explore the processing options
available for building data analytics solutions in Azure. They will explore Azure Synapse Analytics, Azure
Databricks, and Azure HDInsight. Delegates will learn what Power Bl is, including its building blocks and how
they work together.

Audience

The audience for this course is individuals who want to learn the fundamentals of database concepts in a
cloud environment, get basic skilling in cloud data services, and build their foundational knowledge of cloud
data services within Microsoft Azure.

Learning Objectives
By actively participating in this course, you will learn about the following:

Describing core data concepts in Azure.

Explaining concepts of relational data in Azure.

Explaining concepts of non-relational data in Azure.

Identifying components of a modern data warehouse in Azure.

FFEFFY

Pre-Requisites

Prerequisite certification is not required before taking this course. Successful Azure Data Fundamentals
delegates start with some basic awareness of computing and Internet concepts, and an interest in extracting
insights from data.

Specifically:
» Experience using a web browser, such as Microsoft Edge.
»  Familiarity with basic data-related concepts, such as working with tables of data in a spreadsheet and
visualizing data using charts.
» A willingness to learn through hands-on exploration.
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Course Contents

Module 1: Explore core data concepts

Delegates will learn the fundamentals of database concepts in a cloud environment, get basic skilling in cloud
data services, and build their foundational knowledge of cloud data services within Microsoft Azure. Delegates
will identify and describe core data concepts such as relational, non-relational, big data, and analytics, and
explore how this technology is implemented with Azure. Delegates will explore the roles, tasks, and
responsibilities in the world of data.

Lessons

Explore core data concepts

Explore roles and responsibilities in the world of data
Describe concepts of relational data

Explore concepts of non-relational data

Explore concepts of data analytics

FFIFFF

After completing this module, delegates will be able to:
»  Show foundational knowledge of cloud data services within Azure.
» Identify and describe core data concepts such as relational, non-relational, big data, and analytics.
» Explain how this technology is implemented with Azure.

Module 2: Explore relational data in Azure

Delegates will learn the fundamentals of database concepts in a cloud environment, get basic skilling in cloud
data services, and build their foundational knowledge of cloud data services within Microsoft Azure. Delegates
will explore relational data offerings, provisioning and deploying relational databases, and querying relational
data through cloud data solutions with Azure.

Lessons
» Explore relational data services in Azure
»  Explore provisioning and deploying relational database services in Azure
»  Query relational data in Azure

After completing this module, delegates will be able to:
» Describe relational data services on Azure.
» Explain provisioning and deploying relational databases on Azure.
»  Query relational data through cloud data solutions in Azure.

Module 3: Explore non-relational data in Azure

Delegates will learn the fundamentals of database concepts in a cloud environment, get basic skilling in cloud
data services, and build their foundational knowledge of cloud data services within Azure. Delegates will
explore non-relational data services, provisioning and deploying non-relational databases, and non-relational
data stores with Microsoft Azure.

Lessons
» Explore non-relational data services in Azure
»  Explore provisioning and deploying non-relational data services on Azure
» Manage non-relational data stores in Azure

After completing this module, delegates will be able to:
» Describe non-relational data services on Azure.
»  Explain provisioning and deploying non-relational databases on Azure.
» Describe non-relational data stores on Azure.
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Module 4: Explore modern data warehouse analytics in Azure

Delegates will learn the fundamentals of database concepts in a cloud environment, get basic skilling in cloud
data services, and build their foundational knowledge of cloud data services within Azure. Delegates will
explore the processing options available for building data analytics solutions in Azure. Delegates will explore
Azure Synapse Analytics, Azure Databricks, and Azure HDInsight. Delegates will learn what Power Bl is,
including its building blocks and how they work together.

Lessons
» Examine components of a modern data warehouse
» Explore data ingestion in Azure
» Explore data storage and processing in Azure
»  Get started building with Power BI

After completing this module, delegates will be able to:
» Describe processing options available for building data analytics solutions in Azure.
» Describe Azure Synapse Analytics, Azure Databricks, and Azure HDInsight.
»  Explain what Microsoft Power Bl is, including its building blocks and how they work together.

Exam Details
This course leads to the DP-900 Microsoft Azure Data Fundamentals exam, which will earn you the
Microsoft Certified: Azure Data Fundamentals certification.
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